[USB 控制器] 部分电脑不能识别

[复制链接]
139|17
 楼主 | 2018-7-9 19:12 | 显示全部楼层 |阅读模式
自己做的板子,CY7C68013A-56,还没有焊上EEPROM(不过有2.2K的上拉电阻),外接电源供电。

在主板USB接口是SiS PCI to USB Enhanced Host Controller的电脑上,能识别VID_04B4/PID_8613,有黄色的小叹号(因为我还没有装CYPRESS的FX2LP开发软件,出现黄色小叹号是正常的)<----这个可以说明我的板子没有硬件上的问题吧?,XP提示高速设备插在了低速接口上;

在主板USB接口是Intel ICH7 Family USB2 Enhanced Host COntroller的电脑上,XP直接显示USB Unknown Device,PID和VID全部是0000,也没有黄色的小叹号。不能识别68013A,也就无法继续后面的开发工作。

试了7、8台INTEL ICH7的电脑均如此,求原因及解决办法。
自己做的板子,CY7C68013A-56,还没有焊上EEPROM(不过有2.2K的上拉电阻),外接电源供电。
在主板USB接口是SiS PCI to USB Enhanced Host Controller的电脑上,能识别VID_04B4/PID_8613,有黄色的小叹号(因为我还没有装CYPRESS的FX2LP开发软件,出现黄色小叹号是正常的)<----这个可以说明我的板子没有硬件上的问题吧?,XP提示高速设备插在了低速接口上;
在主板USB接口是Intel ICH7 Family USB2 Enhanced Host COntroller的电脑上,XP直接显示USB Unknown Device,PID和VID全部是0000,也没有黄色的小叹号。不能识别68013A,也就无法继续后面的开发工作。
试了7、8台INTEL ICH7的电脑均如此,求原因及解决办法。
| 2018-7-9 19:14 | 显示全部楼层
VID/PID识别成0000是因为68013A枚举没有成功
 楼主 | 2018-7-9 19:16 | 显示全部楼层
但是同一块板子,同样的延长USB线,在SIS上能识别,在INTEL上不能识别,难道是接口阻抗的问题?
| 2018-7-9 19:19 | 显示全部楼层
也有道理啊
 楼主 | 2018-7-9 19:22 | 显示全部楼层
由于68013A的D+和D-位置刚好和USB母头针脚位置相反,因此走线上D-比D+稍微多绕了2~3mm。其他关于芯片关键引脚(WAKEUP,RESET,SDA,SCL,RESERVED)上拉或接地我都检查过了,没有问题。
| 2018-7-9 19:24 | 显示全部楼层
以前有人发了一个类似的贴,说能在Intel 82801E上识别,不能在82801G上识别,但是没有讲解决办法。
| 2018-7-9 19:27 | 显示全部楼层
没按评估板设计电路,再就是板子做的烂,没他解。
| 2018-7-9 19:29 | 显示全部楼层

主板上与USB相关的芯片组都是经过测试与兼容认证的,所以不用怀疑电脑主板的问题。我觉得还是你的电路板设计的有问题。作为对比,你可以找一块好的开发板,在同样的条件下对比测试一下。
| 2018-7-9 19:31 | 显示全部楼层

我觉得有可能是你购买的芯片的问题。。这个可能性比较大。。
芯片如人的大脑。。占主导呀。。
 楼主 | 2018-7-9 19:35 | 显示全部楼层
我找了一块现成的开发板,PC能正确识别并下载固件程序到EEPROM。我把这个开发板上的EEPROM直接跳线到我的板子上,我的68013A能按照这个EEPROM内的程序进行配置
| 2018-7-9 19:37 | 显示全部楼层
怎么配置的
 楼主 | 2018-7-9 19:39 | 显示全部楼层
上电CLKOUT=12MHz,配置后变成48MHz
| 2018-7-9 19:42 | 显示全部楼层
你的68013A工作是正常的吧?
 楼主 | 2018-7-9 19:44 | 显示全部楼层
我感觉也是,RESET之后仍然可以通过示波器看见CLKOUT从12变成48MHz。但PC还是unknown Device。
| 2018-7-9 19:47 | 显示全部楼层
难道是你的板子上68013A的D+D-和PC上的US口之间有问题?
| 2018-7-9 19:50 | 显示全部楼层
我遇到68013a unknown device,最后原因:
我在AVCC--VCC,AGND--GND之间都加了磁珠隔离。
68013没问题。68013A就总是“unknown device”
最后把磁珠全短路,问题就解决了。
 楼主 | 2018-7-9 19:52 | 显示全部楼层

是吗?那我吧磁珠拆了试试。
 楼主 | 2018-7-9 19:55 | 显示全部楼层
果然是磁珠的问题。感谢~~
扫描二维码,随时随地手机跟帖
您需要登录后才可以回帖 登录 | 注册

本版积分规则

快速回复

您需要登录后才可以回帖
登录 | 注册
高级模式
我要创建版块 申请成为版主

论坛热帖

快速回复 返回顶部 返回列表