GD32F450VIT6连接不上Jlink

[复制链接]
705|12
 楼主 | 2017-10-27 10:55 | 显示全部楼层 |阅读模式
大家好,头次使用GD32的单片机,出现了一些问题,首先就是连接问题,我在建立好工程之后,将project的Device选择成为是GD32F450VIT6后,在Debug里选择Jlink,点击Settings后采用SW的方式,此时不能查询到连接到的设备,也就是说SWDID没有数值,此时也不能下载仿真,但是我将project的Device选择成为是STM32F429VIT6后就可以,我的keil软件是5.23版本,关于GD的库也都添加了,工程仿真编译也都通过了,但是就是不能选择成为GD32F450VIT6这个芯片,大家有遇到这个问题吗?难道是我的keil软件版本太高?
 楼主 | 2017-10-27 10:58 | 显示全部楼层
本帖最后由 wow1919 于 2017-10-27 11:00 编辑

具体的图片




本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?注册

x
| 2017-10-28 09:51 | 显示全部楼层
这个问题比较奇怪,没碰到过,可以试试把SWD的速度调低一点。或者打开jlink.exe,然后输入usb,回车,看看是否连接好。如果用jlink.exe命令行没有连接上,基本可以判断是板子硬件问题。请确认供电是否正常,焊接是否良好,SWD接线是否正确等。如果不能解决,请联系我远程看一下。375880228@qq.com
 楼主 | 2017-10-30 08:06 | 显示全部楼层
应该不是硬件问题,因为我把Device改为stm32f429就可以正常的下载以及调试,目前我都是在此模式下进行这下载及调试,如果硬件有问题的话应该是都不能下载调试的。另外jlink也是一样不能连接
 楼主 | 2017-10-30 08:07 | 显示全部楼层
感觉是软件版本有些问题
| 2017-11-24 19:50 | 显示全部楼层
你好,问一下 你这个问题解决没有 ,我也碰到了 我是F103,
 楼主 | 2018-1-5 12:34 | 显示全部楼层
Fliger007 发表于 2017-11-24 19:50
你好,问一下 你这个问题解决没有 ,我也碰到了 我是F103,

还没有解决,只能使用STM32的配置,你解决了吗?
| 2018-1-5 12:51 | 显示全部楼层
wow1919 发表于 2018-1-5 12:34
还没有解决,只能使用STM32的配置,你解决了吗?

芯片有没有问题?
| 2018-1-5 14:55 | 显示全部楼层
Fliger007 发表于 2017-11-24 19:50
你好,问一下 你这个问题解决没有 ,我也碰到了 我是F103,

请问,问题解决了吗?如果没有请和我联系,我安排FAE和你沟通,我的电话:15801804134
| 2018-1-5 14:55 | 显示全部楼层
请问,问题解决了吗?如果没有请和我联系,我安排FAE和你沟通,我的电话:15801804134
| 2018-1-5 14:55 | 显示全部楼层
请问,问题解决了吗?如果没有请和我联系,我安排FAE和你沟通,我的电话:15801804134
| 2018-1-5 20:56 | 显示全部楼层
wow1919 发表于 2018-1-5 12:34
还没有解决,只能使用STM32的配置,你解决了吗?

解决了,重装电脑系统 先安装keil和jlink 然后就解决了。。。。
| 2018-1-5 20:57 | 显示全部楼层
cc304294 发表于 2018-1-5 14:55
请问,问题解决了吗?如果没有请和我联系,我安排FAE和你沟通,我的电话:15801804134 ...

解决了,重装电脑系统 先安装keil和jlink 然后就解决了。。。。
扫描二维码,随时随地手机跟帖
您需要登录后才可以回帖 登录 | 注册

本版积分规则

快速回复

您需要登录后才可以回帖
登录 | 注册
高级模式
我要创建版块 申请成为版主

论坛热帖

快速回复 返回顶部 返回列表