[技术求助] 编译时总是提示不认识 HAL_BOARD_INIT()这个定义

[复制链接]
289|16
| 2018-7-10 20:10 | 显示全部楼层
错误指向哪
 楼主 | 2018-7-10 20:12 | 显示全部楼层

错误都是指向两个文件中的  HAL_BOARD_INIT();行。
| 2018-7-10 20:14 | 显示全部楼层

啥时候出现的
 楼主 | 2018-7-10 20:17 | 显示全部楼层
这个问题是我在修改hal_board_cfg.h文件时,不小心出现的,
| 2018-7-10 20:19 | 显示全部楼层
后来呢
 楼主 | 2018-7-10 20:21 | 显示全部楼层
后来把文件改回去也还是出现这样的错误
| 2018-7-11 18:16 | 显示全部楼层
都有什么提示信息
 楼主 | 2018-7-11 18:19 | 显示全部楼层

ZMain.c  文件编译错误:
Error[Pe007]: unrecognized token C:\Texas Instruments\ZStack-CC2530-2.3.1-1.4.0\Projects\zstack\ZMain\TI2530DB\ZMain.c 85
Error[Pe029]: expected an expression C:\Texas Instruments\ZStack-CC2530-2.3.1-1.4.0\Projects\zstack\ZMain\TI2530DB\ZMain.c 85
Error while running C/C++ Compiler

hal_assert.c  文件编译错误:
Error[Pe007]: unrecognized token C:\Texas Instruments\ZStack-CC2530-2.3.1-1.4.0\Components\hal\common\hal_assert.c 125

Error[Pe029]: expected an expression C:\Texas Instruments\ZStack-CC2530-2.3.1-1.4.0\Components\hal\common\hal_assert.c 125

Error while running C/C++ Compiler
| 2018-7-11 18:22 | 显示全部楼层

软件版本是啥
 楼主 | 2018-7-11 18:24 | 显示全部楼层

编译软件版本是EW8051-EV-751A
| 2018-7-11 18:27 | 显示全部楼层
hal_board_cfg.h文件你找个原版的试试
 楼主 | 2018-7-11 18:29 | 显示全部楼层
谢谢!我卸载了重新安装一遍就可以了。实在不清楚为什么这样。
| 2018-7-11 18:31 | 显示全部楼层
我猜是那个被修改的hal_board_cfg.h文件,你改回去之后有符号错误
 楼主 | 2018-7-11 18:33 | 显示全部楼层
也许是那样的。不过找了半天都没找到其它符号。把那个cfg文件复制了一份放到了原安装路径的文件夹内,打算重装后对比一下的,结果卸载ztack时没有注意,把全部文件都给删除了。
| 2018-7-11 18:36 | 显示全部楼层

在ztack里面还没有把led灯点亮(我用的P1.2,P1.3口),在hal_board_cfg.h里面修改后不成功,在main()和 GenericApp_Init()里初始化io也不行呢。
打开zigbee板子,就开始头不舒服,好像这2.4G辐射的事?
 楼主 | 2018-7-11 18:38 | 显示全部楼层
还好,结贴了哈
扫描二维码,随时随地手机跟帖
您需要登录后才可以回帖 登录 | 注册

本版积分规则

快速回复

您需要登录后才可以回帖
登录 | 注册
高级模式
我要创建版块 申请成为版主

论坛热帖

快速回复 返回顶部 返回列表