[电路/定理] LM311过零比较器的问题

[复制链接]
1214|33
 楼主 | 2018-7-12 17:25 | 显示全部楼层 |阅读模式
按照这个电路来调试,在7脚加了1K的电阻,为什么并没有输出正弦波,求救大侠,走过路过请您帮忙看一眼,谢谢!

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?注册

x

评论

xch 2018-7-13 12:22 回复TA
估计你的信号源坏了。 不用信号源,直接用手摸输入端 PIN2试试 
面朝大海09 2018-7-13 13:12 回复TA
@xch :信号源没有坏,示波器有波形 
xch 2018-7-13 14:54 回复TA
@面朝大海09 :第二脚有波形? 
面朝大海09 2018-7-13 16:28 回复TA
@xch 换了直插的芯片,估计是我的芯片有问题,感谢感谢 

评分

参与人数 1威望 +1 收起 理由
king5555 + 1 作成比较器沒法输出正弦波。
| 2018-7-13 10:43 | 显示全部楼层
唉,不会自己看数据手册,看看教科书的运放原理?
测量一下各关键节点的电压波形?
你想让大家猜谜吗?
如此简单的电路,先理好思路。

评论

面朝大海09 2018-7-13 10:49 回复TA
请问您有哪不清楚 
gx_huang 2018-7-13 11:07 回复TA
@面朝大海09 :请问你测试了哪些点?输入信号波形幅度是多少?3脚的电压是多少?你连这些基本的都不提供,别人怎么回答?如果你会提供这些,估计你也不会在这里问大家了,你应该就会明白了。 
面朝大海09 2018-7-13 11:12 回复TA
@gx_huang :输入端是有信号的,3脚接地,做过零比较器,输入50HZ正弦波,想要输出方波,供电正负12V和正负6V都测试过了,7脚一直输出低电平,上拉电阻1K和500欧的都试过了,只是加上电源电流比较大,有十几到20几毫安,请问还有什么不清楚的地方吗? 
面朝大海09 2018-7-13 11:13 回复TA
@gx_huang :输入端是有信号的,3脚接地,做过零比较器,输入50HZ正弦波,想要输出方波,供电正负12V和正负6V都测试过了,7脚一直输出低电平,上拉电阻1K和500欧的都试过了,只是加上电源电流比较大,有十几到20几毫安,请问还有什么不清楚的地方吗? 
面朝大海09 2018-7-13 11:16 回复TA
@gx_huang :我试过单电源供电是有信号输出的,所以想找问题是出在哪了,如果电流太大烧了的话,我只要一加上正负电源电流就很大,所以不知道问题出在哪,但是电流是超过datasheet给的7.5毫安的电流了。 
gx_huang 2018-7-13 11:24 回复TA
@面朝大海09 :你看清楚我的问题么?输入50Hz正弦波,幅度多大?直流偏置是多少?不就一个比较器功能么,示波器看看各点波形呀,波形当然还得看直流和交流电平呀。如果一切都对的,就看看焊接问题了。你应该把输入信号部分电路也画上。 
面朝大海09 2018-7-13 11:29 回复TA
@gx_huang :输入信号用的信号发生器。50HZ,高电平5V,低电平-5V,没有偏置,正负3V的也试过了,输出只有低电平,不能看各点的波形啊,输入信号用的信号发生器,输入信号用的信号发生器,说三遍! 
面朝大海09 2018-7-13 11:33 回复TA
@gx_huang :会不会是芯片不合适啊,焊接没有虚焊,测试过了 
gx_huang 2018-7-13 11:37 回复TA
@面朝大海09 :没有示波器吗?先买一个,先买一个,先买一个! 
面朝大海09 2018-7-13 11:50 回复TA
@gx_huang :有示波器啊,各个点的波形没办法看吧 
 楼主 | 2018-7-13 16:29 | 显示全部楼层
统一回复,电路没有问题,是我芯片的问题,感谢大家的帮助!!!
 楼主 | 2018-7-12 17:26 | 显示全部楼层
3脚接了地
| 2018-7-12 21:06 | 显示全部楼层
5k大了,最多!1k,或者510欧
| 2018-7-13 08:34 | 显示全部楼层
这就是个比较器电路,怎么能输出正弦波呢?应该是方波吧
| 2018-7-13 09:14 | 显示全部楼层
比较器是输出矩形波的呀
 楼主 | 2018-7-13 10:20 | 显示全部楼层
tototm 发表于 2018-7-12 21:06
5k大了,最多!1k,或者510欧

我改成了500欧和1K仍然没有输出,7脚一直是低电平,我输入的信号是50Hz的正弦波,出不来方波
 楼主 | 2018-7-13 10:20 | 显示全部楼层
xiaxingxing 发表于 2018-7-13 09:14
比较器是输出矩形波的呀

说错了,一直是低电平,没有输出方波
 楼主 | 2018-7-13 10:21 | 显示全部楼层
蒙面男@蒙面女王 发表于 2018-7-13 08:34
这就是个比较器电路,怎么能输出正弦波呢?应该是方波吧

对的,方波,没有输出方波,不知道是哪的原因,已经测了好几个了
| 2018-7-13 10:22 | 显示全部楼层
难道是已经烧了?
 楼主 | 2018-7-13 10:22 | 显示全部楼层
蒙面男@蒙面女王 发表于 2018-7-13 08:34
这就是个比较器电路,怎么能输出正弦波呢?应该是方波吧

对的,方波,没有输出方波,不知道是哪的原因,已经测了好几个了
 楼主 | 2018-7-13 10:25 | 显示全部楼层
戈卫东 发表于 2018-7-13 10:22
难道是已经烧了?

我按照这个电路,电流有10几20毫安,不过我重测了好几个,电流并没有降下来
| 2018-7-13 14:09 | 显示全部楼层
再看下数据手册。
| 2018-7-16 09:52 | 显示全部楼层
我做过上M的比较都没有问题!
| 2018-7-16 09:53 | 显示全部楼层
可能是ic本身有问题!
扫描二维码,随时随地手机跟帖
您需要登录后才可以回帖 登录 | 注册

本版积分规则

快速回复

您需要登录后才可以回帖
登录 | 注册
高级模式
我要创建版块 申请成为版主

论坛热帖

关闭

热门推荐上一条 /7 下一条

快速回复 返回顶部 返回列表