[技术问答] 关于新塘N76E003低功耗

[复制链接]
263|11
 楼主 | 2018-12-6 15:56 | 显示全部楼层 |阅读模式
看了很多例程,尝试写N76E003的低功耗处理,无论怎么改,电流都在十几二十ma,clr_EBOD用了,ADC也关了,IO配置也为准双向了,之后进行set_PD,可电流始终不减,还请各位大牛指教,下面附上例程。

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?注册

x
| 2018-12-6 16:25 | 显示全部楼层
啥代码都不写,编程选项配置关闭WDT,main函数只设置GPIO和PD,看看啥情况。
数据手册正常工作电流才几个毫安,如果有20多,显然是测试方法有问题。
 楼主 | 2018-12-6 16:33 | 显示全部楼层
gx_huang 发表于 2018-12-6 16:25
啥代码都不写,编程选项配置关闭WDT,main函数只设置GPIO和PD,看看啥情况。
数据手册正常工作电流才几个毫 ...

按你说的操作,的确还是有二十多ma,请问正确的姿势应该如何操作?
| 2018-12-6 19:50 | 显示全部楼层
luoyejian818 发表于 2018-12-6 16:33
按你说的操作,的确还是有二十多ma,请问正确的姿势应该如何操作?

你测试时,保证测试的是MCU的电流吗?是否意外包含了其它电路的电流?
如果测试方法没有问题,就是芯片坏了有漏电。
难道芯片手册会作假?
市面上很多51芯片,我都测试过,大部分电流都小于10mA的。
| 2018-12-6 19:56 | 显示全部楼层
你是不是测错电流了。
 楼主 | 2018-12-6 20:32 | 显示全部楼层
heisexingqisi 发表于 2018-12-6 19:56
你是不是测错电流了。

电流表串在电源和开发板之间   电流表正极接电源正极  负极接开发板正极   开发板地接电源地   这样正确么
| 2018-12-6 20:36 | 显示全部楼层
luoyejian818 发表于 2018-12-6 20:32
电流表串在电源和开发板之间   电流表正极接电源正极  负极接开发板正极   开发板地接电源地   这样正确 ...

这不正确,你的开发板是官方的板子吧,上面是不是有编程器?你这连编程器的电流都测进去了。要在最小系统供电那测。
 楼主 | 2018-12-6 20:37 | 显示全部楼层
heisexingqisi 发表于 2018-12-6 20:36
这不正确,你的开发板是官方的板子吧,上面是不是有编程器?你这连编程器的电流都测进去了。要在最小系统 ...

我是淘宝买的很便宜的开发板,十块一个的那种,几乎没什么外设的
| 2018-12-6 22:48 | 显示全部楼层
luoyejian818 发表于 2018-12-6 20:37
我是淘宝买的很便宜的开发板,十块一个的那种,几乎没什么外设的

几乎这种就不好定义了。因为任何一个外部元件都可能是电流的消耗根源。
| 2018-12-7 08:59 | 显示全部楼层
应该是除了最小系统外的其他电路有损耗。
| 2018-12-7 08:59 | 显示全部楼层
这个功耗测试,是测的芯片本身的,不管其他外部元件。
 楼主 | 2018-12-7 22:43 | 显示全部楼层
huangcunxiake 发表于 2018-12-7 08:59
这个功耗测试,是测的芯片本身的,不管其他外部元件。

今天关了大部分的   还有3ma……可能还没找到一些地方
扫描二维码,随时随地手机跟帖
您需要登录后才可以回帖 登录 | 注册

本版积分规则

快速回复

您需要登录后才可以回帖
登录 | 注册
高级模式
我要创建版块 申请成为版主

论坛热帖

快速回复 返回顶部 返回列表