[电路/定理] 峰值检测电路

[复制链接]
316|14
 楼主 | 2019-8-13 16:42 | 显示全部楼层 |阅读模式
本帖最后由 MiniNico 于 2019-8-14 09:22 编辑

最近做一个峰值检测电路,仿真是成功了,但是实际电路失败。
各路大神来指导指导。
仿真图1:回路接通

1

1

仿真图2:回路断开

2

2



图上电压表2,3红字标注的实际值搞反了表2表3标注值互调位置
实际U3,U4部分存在问题,不知道为什么。
S2闭合放电,也无效。

网上找的电路图,IC是拿手上的能用的AD810。
仿真成功了,就打PCB样板回来试,结果失败了。
用示波器一路跟踪信号,信号一直到D2的P端都是正常的,D2的N端(S1闭合)就不正常了。
只要S1一闭合,C4的电压就达到2.8V,比S1上的电压高,D2反偏了,C4无法充电。
一旦S1断开,C4电压经过R12放电减小到0.015V。但是输出异常,达到3.8V。
U4工作不正常。

使用特权

评论回复

评论

blade55 2019-8-17 09:38 回复TA
不会就学嘛,总不能因为容易用就用没有的东西吧 
MiniNico 2019-8-16 15:39 回复TA
@blade55 :Tina好难用啊,不会用,网上都没什么教程。还是multisim易上手,直观。 
blade55 2019-8-15 15:45 回复TA
@MiniNico :用TINA或OrCAD PSpice 
MiniNico 2019-8-14 11:52 回复TA
@blade55 :那用什么软件仿真?这电路还能救吗? 
blade55 2019-8-14 10:29 回复TA
Multisim的仿真结果距实际相差较大,做设计不要用它。 
| 2019-8-13 19:06 | 显示全部楼层
连个示波器都没有。。。。。

使用特权

评论回复

评论

MiniNico 2019-8-14 09:09 回复TA
有示波器啊,波形到D2的P端都是正常的,N端往后是恒压,但电压不对 
| 2019-8-13 20:46 | 显示全部楼层
不知道哪里失敗了,要讲清楚。

使用特权

评论回复

评论

MiniNico 2019-8-14 09:12 回复TA
正常结果应该如图1所示,U4输出1.9V左右的电压,但是实际上是2.88V。断开S1,正常输出应该0V,但是实际3.38V. 
| 2019-8-14 21:25 | 显示全部楼层
R11弄大大些。前级端570欧姆也太太小了i实测是对的,仿真是错的。

使用特权

评论回复

评论

MiniNico 2019-8-16 09:57 回复TA
实际电路工作不正常啊,U4输出随着信号的变大而变小,随着信号的变小而变大 
| 2019-8-16 13:45 | 显示全部楼层
您去评论,我沒 法给你回复。既然已经实作,那就修改再实测。板子在你手中,不在我这。

使用特权

评论回复
| 2019-8-17 09:47 | 显示全部楼层
每一级的测量点有没有数据啊,瞎问,瞎猜。于事无补。

使用特权

评论回复
| 2019-8-17 09:48 | 显示全部楼层
在上升阶段,是否符合OP的虚短原则。

使用特权

评论回复
扫描二维码,随时随地手机跟帖
*滑动验证:
您需要登录后才可以回帖 登录 | 注册

本版积分规则

我要发帖 投诉建议 创建版块 申请版主

快速回复

您需要登录后才可以回帖
登录 | 注册
高级模式

论坛热帖

关闭

热门推荐上一条 /6 下一条

在线客服 快速回复 返回顶部 返回列表