[电路/定理] AD采集信号处理的问题(悬赏2000元人民币)

[复制链接]
1235|29
 楼主 | 2019-8-21 10:28 | 显示全部楼层 |阅读模式
本帖最后由 Cjy_JDxy 于 2019-8-23 08:38 编辑

2.jpg
我的传感器采集处理电路有问题。我测试波形是这样的:
1.jpg 2.jpg
后来我测试了一下,AD出的电压值在0-40KN这一块一直是0.3几V,不怎么变化。
请高手指点,怎么才能让电压值正常,即从0-40KN电压变化是线性的。谢谢!
私聊,QQ:413132614

使用特权

评论回复
 楼主 | 2019-8-21 11:58 | 显示全部楼层
传感器的输出是线性变化的。

使用特权

评论回复
| 2019-8-21 13:12 | 显示全部楼层
Cjy_JDxy 发表于 2019-8-21 11:58
传感器的输出是线性变化的。

先断开ADC的连接,用万用表测试INA188输出的曲线看是否正确

使用特权

评论回复
| 2019-8-21 13:36 | 显示全部楼层
放大器电路是错误的,如果是+-5v就是好的

使用特权

评论回复
| 2019-8-23 16:04 | 显示全部楼层
顶楼上,INA188 输入电压:(V–) + 0.1V 至 (V+) – 1.5V  这样输入电压很小的时候,会有一段非线性

使用特权

评论回复
| 2019-8-23 16:21 | 显示全部楼层
1 你先给出传感器出来的信号波形
2 如果确定传感器出来的信号波形线性,那么 确定是什么幅值的信号,一般来说 仪表运放 推荐正负电压供电

使用特权

评论回复
 楼主 | 2019-8-23 16:24 | 显示全部楼层
jjjyufan 发表于 2019-8-23 16:21
1 你先给出传感器出来的信号波形
2 如果确定传感器出来的信号波形线性,那么 确定是什么幅值的信号,一般来 ...

不好弄波形,太小了,不好测。用万用表量好像是线性的。

使用特权

评论回复
| 2019-8-23 16:26 | 显示全部楼层
Cjy_JDxy 发表于 2019-8-23 16:24
不好弄波形,太小了,不好测。用万用表量好像是线性的。

应该示波器抓波形啊,
万用表哪能看出来是线性

使用特权

评论回复
| 2019-8-23 16:38 | 显示全部楼层
四五六楼正解,用双电源+-10V给运放供电,问题就能解决了

使用特权

评论回复
 楼主 | 2019-8-23 16:39 | 显示全部楼层
jjjyufan 发表于 2019-8-23 16:26
应该示波器抓波形啊,
万用表哪能看出来是线性

感觉不好弄。力压上时时间比较长,传感器信号很小,mV级。

使用特权

评论回复
 楼主 | 2019-8-23 16:41 | 显示全部楼层
weilaiheike 发表于 2019-8-23 16:38
四五六楼正解,用双电源+-10V给运放供电,问题就能解决了

谢谢!到底是+-10V还是+-5V啊

使用特权

评论回复
| 2019-8-23 16:47 | 显示全部楼层
具体用5V双电源还是10V双电源取决于你需要把信号放大到多少V给AD采样

使用特权

评论回复
| 2019-8-23 16:56 | 显示全部楼层
活该。找那个让你用仪表放大器的傻瓜去呗。

使用特权

评论回复
 楼主 | 2019-8-23 17:04 | 显示全部楼层
weilaiheike 发表于 2019-8-23 16:47
具体用5V双电源还是10V双电源取决于你需要把信号放大到多少V给AD采样

谢谢!我需要0-3.3V之间。

使用特权

评论回复
 楼主 | 2019-8-23 17:05 | 显示全部楼层
R2D2 发表于 2019-8-23 16:56
活该。找那个让你用仪表放大器的傻瓜去呗。

朴昌范,你不要幸灾乐祸。
你那个电路也不行,5V供电,电平不匹配。

使用特权

评论回复

评论

R2D2 2019-8-23 17:17 回复TA
公模电压4.3V怎么就不匹配了? 
| 2019-8-23 17:48 | 显示全部楼层
本帖最后由 zyj9490 于 2019-8-23 17:53 编辑
Cjy_JDxy 发表于 2019-8-23 16:24
不好弄波形,太小了,不好测。用万用表量好像是线性的。

从5V经过1K与100欧电阻分压得到0.5V,在100欧电阻并一个10UF的电容,将0.5V电压跟仪运的REF脚相连,原来的地要切断。在程序上作零点校正即可。以上是临时方案,可实现低阻的要求,下一板加一个OPBUF下,0.5V输出加到REF脚即可,

使用特权

评论回复
 楼主 | 2019-8-23 17:52 | 显示全部楼层
Cjy_JDxy 发表于 2019-8-23 17:05
朴昌范,你不要幸灾乐祸。
你那个电路也不行,5V供电,电平不匹配。

2.jpg
STM32高电平3.3V,而ADS1220高电平0.7DVDD。
0.7*5=3.5V

使用特权

评论回复

评论

Cjy_JDxy 2019-8-23 19:13 回复TA
@R2D2 :我跟你比不了,你是全论坛最吊的人。 
R2D2 2019-8-23 18:14 回复TA
@Cjy_JDxy :比你屌100倍。 
Cjy_JDxy 2019-8-23 18:10 回复TA
@R2D2 :那样靠谱吗?你那样用过吗?你总是很吊的样子。 
R2D2 2019-8-23 18:07 回复TA
这点破事儿还是个问题?找个FT引脚配置成OD输出就跟5V的ADS连上了,这么简单的东西居然不会? 
 楼主 | 2019-8-23 17:55 | 显示全部楼层
zyj9490 发表于 2019-8-23 17:48
从5V经过1K与100欧电阻分压得到0.5V,在100欧电阻并一个10UF的电容,将0.5V电压跟仪运的REF脚相连,原来的 ...

谢谢!我试试。

使用特权

评论回复
| 2019-8-23 20:23 | 显示全部楼层
Cjy_JDxy 发表于 2019-8-23 17:05
朴昌范,你不要幸灾乐祸。
你那个电路也不行,5V供电,电平不匹配。

R2D2是老朴?楼主是叶子?

使用特权

评论回复
| 2019-8-23 20:24 | 显示全部楼层
1.你要求的精度如何?
2.传感器出来是什么信号,电压还是电流?信号范围多大

使用特权

评论回复
扫描二维码,随时随地手机跟帖
您需要登录后才可以回帖 登录 | 注册

本版积分规则

我要发帖 投诉建议 创建版块 申请版主

快速回复

您需要登录后才可以回帖
登录 | 注册
高级模式

论坛热帖

关闭

热门推荐上一条 /6 下一条

在线客服 快速回复 返回顶部 返回列表