[运放] 运放莫名饱和

[复制链接]
843|19
 楼主 | 2019-8-22 07:47 | 显示全部楼层 |阅读模式
一个认为比较成熟的运放放大电路,工作过程中,在电流为零(currB和Bus-无偏差)的时候,一段时间后运放输出莫名出现饱和现象,输出由2.5V变为4.1V。求教该如何分析?另外布线是否会有影响。多谢了!
电流放大.jpg

使用特权

评论回复

评论

zyj9490 2019-8-22 14:08 回复TA
测量数据很重要!!!! 
| 2019-8-22 07:52 | 显示全部楼层
2.5V正常么?

使用特权

评论回复
| 2019-8-22 08:18 | 显示全部楼层
currB和Bus- 电压多少?单电源和双电源的电路会不一样。饱和当属正常。

使用特权

评论回复
 楼主 | 2019-8-22 08:32 | 显示全部楼层

2.5V是TL431产生了,有很微小的抖动

使用特权

评论回复
 楼主 | 2019-8-22 08:32 | 显示全部楼层
king5555 发表于 2019-8-22 08:18
currB和Bus- 电压多少?单电源和双电源的电路会不一样。饱和当属正常。

两个几乎为零,因为没有电流流过~

使用特权

评论回复
| 2019-8-22 09:10 | 显示全部楼层
autumwind 发表于 2019-8-22 08:32
两个几乎为零,因为没有电流流过~

两个大约是接地的是吧!直流偏置的电流您沒算进去!

使用特权

评论回复
| 2019-8-22 11:01 | 显示全部楼层
电路是很标准的差分放大电路。
这种出问题比较难分析,能导致输出饱和的因素从电路上分析不出来。
换用低压CMOS的运放试试看

使用特权

评论回复
| 2019-8-22 11:44 | 显示全部楼层
本帖最后由 zyj9490 于 2019-8-22 11:52 编辑

输入端开路时,包和的吧,开路时,输出2.5V,如VIN-接地,则变成2.5*20=50V同,不包和才怪。

使用特权

评论回复
 楼主 | 2019-8-22 12:27 | 显示全部楼层
yanwen217 发表于 2019-8-22 11:01
电路是很标准的差分放大电路。
这种出问题比较难分析,能导致输出饱和的因素从电路上分析不出来。
换用低压 ...

嗯,的确是这样的。该电路在另一个板子上运行正常。
所以一直担心布板会不会有影响,但是测量电源、地都没问题~~~

使用特权

评论回复
 楼主 | 2019-8-22 12:29 | 显示全部楼层
zyj9490 发表于 2019-8-22 11:44
输入端开路时,包和的吧,开路时,输出2.5V,如VIN-接地,则变成2.5*20=50V同,不包和才怪。 ...

Vin-没有直接接地,前端一个电路,而且放大倍数对于2.5V其实是1倍,所以单纯2.5V应该不会饱和~~

使用特权

评论回复
 楼主 | 2019-8-22 12:30 | 显示全部楼层
king5555 发表于 2019-8-22 09:10
两个大约是接地的是吧!直流偏置的电流您沒算进去!

这个直流偏置电流不知道指啥?能否解释一下,多谢了。

使用特权

评论回复
| 2019-8-22 13:14 | 显示全部楼层
autumwind 发表于 2019-8-22 12:30
这个直流偏置电流不知道指啥?能否解释一下,多谢了。

两个输入的状态是什么,你一直讲不清楚,这种有负反馈的可以仿真。若两个输入是接地的,在理想运放时的输出竔电平就是2.5V。自个仿真去。

使用特权

评论回复
| 2019-8-22 13:48 | 显示全部楼层
如果运放输入端currB开路、Bus-对地电压为0,相当于差分放大器输入+2.5V的差分电压,运放当然会饱和。
改进:在Bus-与+2.5V之间连接一个20k或阻值更小的电阻。

使用特权

评论回复
| 2019-8-22 14:07 | 显示全部楼层
autumwind 发表于 2019-8-22 12:29
Vin-没有直接接地,前端一个电路,而且放大倍数对于2.5V其实是1倍,所以单纯2.5V应该不会饱和~~ ...

量输入端的电压就清楚了吗?或者二个输入端电位,OP,输出的电位量下,给大家参考,什么数据也没有就让大家猜?

使用特权

评论回复
| 2019-8-22 15:15 | 显示全部楼层
仅仅图纸这样,currB和Bus短路,悬空,是不可能产生短路的,既然出现饱和,你可以实际测量6脚和5脚电平到底多少,应该可以从外围入手分析到原因。

使用特权

评论回复
| 2019-8-22 21:26 | 显示全部楼层
做个简单的仿真不就完了,你这不饱和才怪呢

使用特权

评论回复
| 2019-8-23 14:44 | 显示全部楼层
本来是双电源供电的,现在通过加2.5V电压加上了,改成单电源供电了,电路上看不出来问题

使用特权

评论回复
| 2019-8-23 15:56 | 显示全部楼层
楼主有没有在C33并联电阻试试?

使用特权

评论回复
| 2019-8-27 22:10 | 显示全部楼层
有没有震荡

使用特权

评论回复
扫描二维码,随时随地手机跟帖
*滑动验证:
您需要登录后才可以回帖 登录 | 注册

本版积分规则

我要发帖 投诉建议 创建版块 申请版主

快速回复

您需要登录后才可以回帖
登录 | 注册
高级模式

论坛热帖

关闭

热门推荐上一条 /5 下一条

在线客服 快速回复 返回顶部 返回列表