[STM32] PT1000 采样数据很不稳定

[复制链接]
674|22
 楼主 | 2019-9-16 11:00 | 显示全部楼层 |阅读模式
5DY44%$~PK[OB1C_~5X1UZU.png
发现纹波比较多

使用特权

评论回复
| 2019-9-16 11:07 | 显示全部楼层
瞎玩儿有个读数就行了。

使用特权

评论回复
 楼主 | 2019-9-16 11:19 | 显示全部楼层
R2D2 发表于 2019-9-16 11:07
瞎玩儿有个读数就行了。

不是玩啊大神

使用特权

评论回复
| 2019-9-16 11:28 | 显示全部楼层

这么烂的原理图是谁画的,谁审核的?

使用特权

评论回复
 楼主 | 2019-9-16 11:36 | 显示全部楼层
R2D2 发表于 2019-9-16 11:28
这么烂的原理图是谁画的,谁审核的?

不是我画的,说说你的高见

使用特权

评论回复
| 2019-9-16 11:41 | 显示全部楼层
肥羊 发表于 2019-9-16 11:36
不是我画的,说说你的高见

你这破图连pt1000接哪里都看不出来。

使用特权

评论回复
| 2019-9-16 16:19 | 显示全部楼层
详细介绍下,好分析问题

使用特权

评论回复
 楼主 | 2019-9-17 13:26 | 显示全部楼层
感动 发表于 2019-9-16 16:19
详细介绍下,好分析问题

输出到AD有纹波

使用特权

评论回复
| 2019-9-17 14:34 | 显示全部楼层
用示波器测测电源、参考电源等地方有纹波吗

使用特权

评论回复
| 2019-9-17 22:24 | 显示全部楼层
这么高的内阻,没纹波才怪

使用特权

评论回复

评论

R2D2 2019-9-19 20:00 回复TA
@Diyer123 :那个电阻算个屁啊,就那么小小面积能吸引多大干扰???更何况正确布线根本不会有可以测试到的干扰。 
Diyer123 2019-9-19 19:14 回复TA
@R2D2 :你这啥眼神?看看运放输出到AD之间串的电阻 
R2D2 2019-9-18 19:45 回复TA
PT1000怎么可能会有多大的内阻???考虑到楼主的图纸画的跟屎一样,就不骂你了。 
 楼主 | 2019-9-18 11:30 | 显示全部楼层
Diyer123 发表于 2019-9-17 22:24
这么高的内阻,没纹波才怪

大神解释一下不懂

使用特权

评论回复
| 2019-9-18 12:24 | 显示全部楼层
1、这原理图画的,专家都要看好久才会明白,运放最好用运放的符号,否则单个运放还凑合,多个运放看花眼了。
2、一个PT1000而已,竟然用2个价格贵的OP333。
3、如果传感器是外接出去的,长线会有很多干扰,肯定要加大滤波。
其实只要一个桥式传感器接法,一个OP333差分放大即可,非线性软件补偿,有钱人呀,就是任性。

使用特权

评论回复
| 2019-9-18 13:20 | 显示全部楼层
连个电桥都没有,直接放大这么任性,不是吧,嗯,你开心就好了

使用特权

评论回复

评论

肥羊 2019-9-18 14:54 回复TA
和30K电阻分压 
 楼主 | 2019-9-18 14:55 | 显示全部楼层
cooldog123pp 发表于 2019-9-18 13:20
连个电桥都没有,直接放大这么任性,不是吧,嗯,你开心就好了

和30K电阻分压

使用特权

评论回复
 楼主 | 2019-9-18 14:55 | 显示全部楼层
cooldog123pp 发表于 2019-9-18 13:20
连个电桥都没有,直接放大这么任性,不是吧,嗯,你开心就好了

没有用电桥

使用特权

评论回复
 楼主 | 2019-9-18 14:57 | 显示全部楼层
gx_huang 发表于 2019-9-18 12:24
1、这原理图画的,专家都要看好久才会明白,运放最好用运放的符号,否则单个运放还凑合,多个运放看花眼了 ...

30K和PT1000分压,第一个电压跟随器

使用特权

评论回复
| 2019-9-18 15:53 | 显示全部楼层
肥羊 发表于 2019-9-18 14:57
30K和PT1000分压,第一个电压跟随器

我都看不懂,你能做好就怪了,这么多网络名不知道干啥的。一看就不是一个好的设计、正确的设计

使用特权

评论回复
| 2019-9-19 09:10 | 显示全部楼层
你这个电路图这样画估计都是新手搞的,运放要用运放的符号来做,方便分析,我把这个电路重新画了一下,第一个运放是跟随器假设输入的PT100信号为Vx,那么经过第一个运放后也是Vx,第二个运放是差动放大,输出的AD值Vad=100k/10k*(3.6V-Vx),如果你的输出AD值很大的话,很有可能就是3.6V电压不稳定造成的,这个位置的3.6V最好用一个电压基准,仅供参考

使用特权

评论回复
 楼主 | 2019-9-19 10:52 | 显示全部楼层
ChaserMCU 发表于 2019-9-19 09:10
你这个电路图这样画估计都是新手搞的,运放要用运放的符号来做,方便分析,我把这个电路重新画了一下,第一 ...

说的跟你的一样,电源是用开关电源可能有影响

使用特权

评论回复
扫描二维码,随时随地手机跟帖
您需要登录后才可以回帖 登录 | 注册

本版积分规则

我要发帖 投诉建议 创建版块 申请版主

快速回复

您需要登录后才可以回帖
登录 | 注册
高级模式

论坛热帖

关闭

热门推荐上一条 /3 下一条

在线客服 快速回复 返回顶部 返回列表