[开发工具] Mplab-x-IDE不能选择开发板对应调试器

[复制链接]
571|18
 楼主 | 2019-11-12 11:17 | 显示全部楼层 |阅读模式
目前我们公司在使用ATMEL的芯片做项目开发。然后ICD4一直不能正常,所以我领导用C21-Xplained开发板上的EDBG模块进行调试和烧录。但是只有他的电脑可以正常使用。在我的电脑上能识别到开发板,但是调试器一直是红色的不可选状态。图里时买的另外一块开发板,也不能选择。

使用特权

评论回复
 楼主 | 2019-11-12 11:18 | 显示全部楼层
请各位使用过的前辈指点一下
批注 2019-11-12 082509.png

使用特权

评论回复
| 2019-11-12 11:32 | 显示全部楼层
你的X ide是什么版本的?

使用特权

评论回复
 楼主 | 2019-11-12 11:59 | 显示全部楼层
CoolSilicon 发表于 2019-11-12 11:32
你的X ide是什么版本的?

5.25

使用特权

评论回复
| 2019-11-12 13:46 | 显示全部楼层

版本没啥问题
加上这个, 看你ICD4的driver也不能用,  是不是你电脑装了 电脑管家之类的软件, 在安装X IDE的时候驱动没有被正确的安装...

使用特权

评论回复
 楼主 | 2019-11-12 13:53 | 显示全部楼层
CoolSilicon 发表于 2019-11-12 13:46
版本没啥问题
加上这个, 看你ICD4的driver也不能用,  是不是你电脑装了 电脑管家之类的软件, 在安装X IDE ...

有什么办法可以检查是否是因为驱动的问题吗?或者Studio7可以导入Mplab-x的项目吗。现在的需求就是给我们自己的芯片下程序进去。

使用特权

评论回复
 楼主 | 2019-11-12 13:54 | 显示全部楼层
CoolSilicon 发表于 2019-11-12 13:46
版本没啥问题
加上这个, 看你ICD4的driver也不能用,  是不是你电脑装了 电脑管家之类的软件, 在安装X IDE ...

或者您知道是缺少哪一个驱动会导致类似的问题吗

使用特权

评论回复
| 2019-11-12 14:13 | 显示全部楼层
1020580286 发表于 2019-11-12 13:54
或者您知道是缺少哪一个驱动会导致类似的问题吗

这个不知道...
只能卸载掉, 然后重启, 检查一下是不是有电脑管家之类的软件, 先全部关掉.
安装的时候, 所有弹出来的框框,都选允许...

使用特权

评论回复
| 2019-11-12 14:30 | 显示全部楼层
你这已经识别了啊. 选择上面那个SN:xxxx

使用特权

评论回复
 楼主 | 2019-11-12 14:34 | 显示全部楼层
奔波儿熊 发表于 2019-11-12 14:30
你这已经识别了啊. 选择上面那个SN:xxxx

识别到了但是不可选

使用特权

评论回复
| 2019-11-12 14:43 | 显示全部楼层
本帖最后由 奔波儿熊 于 2019-11-12 14:49 编辑

你建的C21的工程? 那肯定不能选4S的这个啊

使用特权

评论回复
 楼主 | 2019-11-12 14:53 | 显示全部楼层
奔波儿熊 发表于 2019-11-12 14:43
你建的C21的工程? 那肯定不能选4S的这个啊

我用c21的开发板也是一样的情况。

使用特权

评论回复
| 2019-11-12 14:59 | 显示全部楼层
那你把c21板子插上去,截个图看看,截全了,左边的工程名, 还有左下角的dashboard(中文版不知道叫啥, 里面会显示器件名字,memory大小等的那个页面)

使用特权

评论回复
 楼主 | 2019-11-12 15:15 | 显示全部楼层
奔波儿熊 发表于 2019-11-12 14:59
那你把c21板子插上去,截个图看看,截全了,左边的工程名, 还有左下角的dashboard(中文版不知道叫啥, 里面会显 ...

刚才又拿C21的板子试了一下 现在可以选择开发板作为调试器,但是编译工具链是Studio的工具,找不到XC32了,和工程设置有所冲突。那么看来可能是编译工具的问题。

使用特权

评论回复
| 2019-11-12 15:26 | 显示全部楼层
1020580286 发表于 2019-11-12 15:15
刚才又拿C21的板子试了一下 现在可以选择开发板作为调试器,但是编译工具链是Studio的工具,找不到XC32了 ...

能用就好,但是硬件工具的选择和编译器没啥关系

使用特权

评论回复
 楼主 | 2019-11-12 15:29 | 显示全部楼层
奔波儿熊 发表于 2019-11-12 15:26
能用就好,但是硬件工具的选择和编译器没啥关系

目前还无法使用,但是可以选择对应的调试器了。

使用特权

评论回复
| 2019-11-12 15:31 | 显示全部楼层
1020580286 发表于 2019-11-12 15:29
目前还无法使用,但是可以选择对应的调试器了。

那现在是什么问题?

使用特权

评论回复
| 2019-11-13 10:38 | 显示全部楼层
版本问题,建议更换版本的,我也是5,25不行,切换到了5.20就可以了

使用特权

评论回复
| 2019-11-14 00:13 | 显示全部楼层
正常情况是可以的,而且还可以自动检测到你的开发板型号。

使用特权

评论回复
扫描二维码,随时随地手机跟帖
您需要登录后才可以回帖 登录 | 注册

本版积分规则

我要发帖 投诉建议 创建版块 申请版主

快速回复

您需要登录后才可以回帖
登录 | 注册
高级模式

论坛热帖