运放莫名其妙振荡,困扰好久了,帮看下,拜谢!

[复制链接]
1133|53
 楼主 | 2019-11-15 17:52 | 显示全部楼层 |阅读模式
本帖最后由 玻璃之城 于 2019-11-18 17:44 编辑

(第一轮整改结果在27楼,感谢论坛,感谢大家!后续整改结果会继续上传希望对别人有用)
上原理图,一个简单的光电转换电路。没有光源输出的情况下,第一级、第二级会出现一个振荡的波形,不知道怎么来的,调了很久了。而且基本每个电路板都是刚开始没有,运行一段时间就一直会有
电源换过电池、台式线性电源,都一样。

C15从1nf~10uf换过无效。
C15直接短接,刚开始没有振荡,后来就一直会有。
C18从1.5pf~0.1nf换过,波形会改变,但是还会有。

R3从200K~1M之间调整,振荡还会有,形状稍微变化。
去掉D1、短接C15不太确定,大部分时间会有,偶尔没有。
请问各位前辈,这个方案是否有问题,这个振荡来自何处,应该怎么处理呢?
QQ截图20191115173457.jpg
第一级10pf反馈电容,第1级输出.jpg
第一级10pf反馈电容,第2级输出.jpg
出现振荡时的波形.jpg

使用特权

评论回复
| 2019-11-15 19:24 | 显示全部楼层
不像振荡,应该是噪音/干扰吧?

使用特权

评论回复
| 2019-11-15 20:21 | 显示全部楼层
这个不是运放振荡,运放振荡会导致饱和的。这个是第一级的2个电容在某频率放大导致的选频。

使用特权

评论回复
| 2019-11-15 21:19 | 显示全部楼层
本帖最后由 king5555 于 2019-11-15 21:23 编辑

C15再串联电阻,C18再加大。放大率过高。运放不是轨对轨或者不是单电源专用的,R6请加大。

使用特权

评论回复
| 2019-11-15 23:08 | 显示全部楼层
光看电路, 没有什么。 回路里带来了正反馈, 引起了自激?

使用特权

评论回复
 楼主 | 2019-11-16 11:31 | 显示全部楼层
king5555 发表于 2019-11-15 21:19
C15再串联电阻,C18再加大。放大率过高。运放不是轨对轨或者不是单电源专用的,R6请加大。 ...

运放是轨对轨,单电源。

使用特权

评论回复
| 2019-11-16 11:41 | 显示全部楼层


旁边桌子都是空的,你们公司就你一个人在战斗?


551695dcf6fae00236.png




想当小公司的工程师,可不简单,从方案到打板测试,到采购元件,一个人一条龙服务。



使用特权

评论回复

评论

icecut 2019-11-18 10:55 回复TA
@xukun977 :所以我怀疑这个示波器是二手的, 并且,还是个坏的 
xukun977 2019-11-18 10:02 回复TA
@icecut :连这个细节都能看到?! 
icecut 2019-11-18 00:28 回复TA
示波器把手上的灰.... 
icecut 2019-11-18 00:28 回复TA
示波器把手上的灰.... 
GavinZ 2019-11-16 13:24 回复TA
对,就一条龙,跟早点摊一样,厨子会计服务员就一个人。 
| 2019-11-16 12:08 | 显示全部楼层
示波器不错。4通道+16CH逻辑分析仪

使用特权

评论回复
| 2019-11-16 13:25 | 显示全部楼层
没看见振荡,就看见噪声干扰了。

使用特权

评论回复
| 2019-11-16 22:27 | 显示全部楼层
本帖最后由 xch 于 2019-11-16 22:29 编辑

用接地金属屏蔽纸将D1 包起来看看。

既然处理交流信号。R12 就不用接地,接个电容就行。

这样R5/R6 偏置电源就可以调到2.5V. 且前后级放大倍数可方便平衡分配。
两片OPA 也应该避免光线照射,金属屏蔽为好

使用特权

评论回复
| 2019-11-16 23:10 | 显示全部楼层
TIA结构,选用的运放GBP为10MHz,反馈电阻为500K,补偿电容C18为2.7pF,很明显前级增益设置过大,运放进入了不稳定区间。
环境中的任何干扰都会导致运放出现衰减震荡。
一种方法是:选用GBP更大的运放,减小前级放大倍数,加大相位补偿电容,在保证带宽的前提下,可以尽量抑制这种不稳定性。
第二,交流耦合电容C15去掉,光电二极管和C15、运放等效输入电容,会很大程度影响运放稳定性,直接让广电二极管工作在偏压模式;
第三,PCB设计的时候,反馈迹线走表层微带,底层参考平面挖空,减小反馈迹线相位滞后,同时减小噪声耦合路径;
第四,光电二极管前级采用窄带滤波片,线路包裹锡箔纸等屏蔽材料并与系统良好接地。
祝你早日成功。

使用特权

评论回复
 楼主 | 2019-11-17 07:55 | 显示全部楼层
世界心 发表于 2019-11-16 23:10
TIA结构,选用的运放GBP为10MHz,反馈电阻为500K,补偿电容C18为2.7pF,很明显前级增益设置过大,运放进入 ...

理论知识扎实,谢谢,我消化一下,做做实验

使用特权

评论回复
| 2019-11-17 09:50 | 显示全部楼层
你直接从AVCC经过20K电阻到第一级的反相输入端,这时候,对电源波动等干扰的放大程度几10倍,再到后面10倍放大,足够你看见那些几百mV的方波了。
最致命的问题就是这里,你对光电二极管的偏置,必须经过特别处理,稳压、退偶,电容旁路等基本上全得加上,才能做为D1的反向偏置使用。否则,电源之间的相互串扰,就足以引起你看见的这样噪音和波动。

使用特权

评论回复
| 2019-11-17 11:33 | 显示全部楼层
噪声和干扰,跟布线关系很大,运放及小信号线远离电源,输出输入分开,信号线尽可能短,尽可能少打过孔,包地

使用特权

评论回复
| 2019-11-17 15:33 | 显示全部楼层
世界心 发表于 2019-11-16 23:10
TIA结构,选用的运放GBP为10MHz,反馈电阻为500K,补偿电容C18为2.7pF,很明显前级增益设置过大,运放进入 ...

真正的专家。666

使用特权

评论回复

评论

GavinZ 2019-11-18 09:11 回复TA
一个专家才能判断另一个是不是专家。 
| 2019-11-17 20:06 | 显示全部楼层
在R8的后面加一个电阻接地试试吧

使用特权

评论回复
| 2019-11-17 20:36 | 显示全部楼层
玻璃之城 发表于 2019-11-17 07:55
理论知识扎实,谢谢,我消化一下,做做实验

运放稍微设计不好,这种噪声都会出现,很难避免。如果对信号质量和带宽要求不高,其实在后级加一个有源滤波器(二阶sallen-key)直接把这种高频噪声滤掉就可以了。

使用特权

评论回复
| 2019-11-17 20:37 | 显示全部楼层
nbiot 发表于 2019-11-17 15:33
真正的专家。666

见笑了,兄弟

使用特权

评论回复
| 2019-11-18 08:44 | 显示全部楼层
输入明显设计有问题啊,我用1G电阻也没事

使用特权

评论回复
 楼主 | 2019-11-18 09:09 | 显示全部楼层
飞鸿留影 发表于 2019-11-18 08:44
输入明显设计有问题啊,我用1G电阻也没事

前辈,能指点一下输入应该怎么设计吗,拜谢!

使用特权

评论回复
扫描二维码,随时随地手机跟帖
*滑动验证:
您需要登录后才可以回帖 登录 | 注册

本版积分规则

我要发帖 投诉建议 创建版块 申请版主

快速回复

您需要登录后才可以回帖
登录 | 注册
高级模式

论坛热帖

关闭

热门推荐上一条 /5 下一条

在线客服 快速回复 返回顶部 返回列表