[MCU] 程序一直停在设置外部晶振那

[复制链接]
706|35
 楼主 | 2019-12-13 20:08 | 显示全部楼层 ||阅读模式
今天发现液晶无法显示以为焊接出问题了,搞了半天才发现程序一直停在设置外部
晶振那,没过去
void Init_Clk()
{
  uchar i;

  BCSCTL1&=~XT2OFF;
  BCSCTL2|=SELM_2+SELS+DIVS_3;

  do
  {
    IFG1&=~OFIFG;
    for(i=255;i>0;i--);
  }while(IFG1&OFIFG);

}

使用特权

评论回复
| 2019-12-13 20:12 | 显示全部楼层
重新焊下

使用特权

评论回复
 楼主 | 2019-12-13 20:15 | 显示全部楼层
刚开始很快就能过,我就过会又拔了插几次

使用特权

评论回复
 楼主 | 2019-12-13 20:17 | 显示全部楼层
过晶振设置部分的速度越来越慢,最后就停了又过不去。

使用特权

评论回复
| 2019-12-13 20:20 | 显示全部楼层
换电容

使用特权

评论回复
 楼主 | 2019-12-13 20:26 | 显示全部楼层

换了电容,不行还是那样。
有时用手碰晶振就好了,我就把晶振接地,又没用。

使用特权

评论回复
| 2019-12-13 20:30 | 显示全部楼层


晶振接地后碰晶振就进不去了,碰晶振和地的连接也没用

使用特权

评论回复
| 2019-12-13 20:33 | 显示全部楼层
只能碰电容和晶振连接的部分才能过设置。

使用特权

评论回复
 楼主 | 2019-12-13 20:36 | 显示全部楼层
对啊,到底什么情况啊,请大家指点下

使用特权

评论回复
| 2019-12-13 20:38 | 显示全部楼层
有没有试着换个晶振呢?

使用特权

评论回复
| 2019-12-13 20:41 | 显示全部楼层


晶振的匹配电容确定是正确的吗?
焊接没有问题吗?

使用特权

评论回复
| 2019-12-13 20:44 | 显示全部楼层
换换晶振的,在看下你的晶振是否在你软件里设定的范围之内的

使用特权

评论回复
| 2019-12-13 20:48 | 显示全部楼层
晶振两边的电容很重要   那个电容是起振电容   如果没有了   晶振不能起振   mcu基本不能工作   呵呵

使用特权

评论回复
| 2019-12-13 20:51 | 显示全部楼层
电容是起振电容 ,离晶振近点

使用特权

评论回复
 楼主 | 2019-12-13 20:54 | 显示全部楼层

好的,我明天去单位试一下,多谢各位大侠了哈,结贴了先

使用特权

评论回复
| 2019-12-13 20:56 | 显示全部楼层

晶振没有起振吧。

使用特权

评论回复
| 2019-12-13 21:01 | 显示全部楼层
看看你的硬件电路看看

使用特权

评论回复
| 2019-12-13 21:04 | 显示全部楼层

选择的是多大电容?

使用特权

评论回复
| 2019-12-13 21:07 | 显示全部楼层
测量晶振是否有信号了吗?

使用特权

评论回复
| 2019-12-13 21:10 | 显示全部楼层
12M晶振需要15pf的电容。

使用特权

评论回复
扫描二维码,随时随地手机跟帖
您需要登录后才可以回帖 登录 | 注册

本版积分规则

我要发帖 投诉建议 创建版块 申请版主

快速回复

您需要登录后才可以回帖
登录 | 注册
高级模式

论坛热帖

在线客服 快速回复 返回顶部 返回列表