搜索

[技术问答] 新手求救:HC32L136在keil中找不到设备问题

[复制链接]
442|15
 楼主 | 2020-5-25 09:05 | 显示全部楼层 |阅读模式
本帖最后由 vinci25031891 于 2020-5-25 09:08 编辑

求救:
我安装了华大cdc驱动后,在设备管理器中看到了设备如下:
但是在keil的debugger中找不到对应设备?

2.png
1.png

使用特权

评论回复
| 2020-5-25 10:27 | 显示全部楼层
看看用CMSIS,就是demo板自带的那个,调试能不能正常。然后再试试其他的JLINK,看行不行。

使用特权

评论回复
| 2020-5-25 10:29 | 显示全部楼层
我感觉最新出来那种调试方法,不太好使,需要多试试。而且不知道支不支持这个型号。

使用特权

评论回复
| 2020-5-25 11:31 | 显示全部楼层
如果你使用的是CMSIS DAP,那么就不要选Jlink呀,选CMSIS DAP工具

使用特权

评论回复
| 2020-5-25 15:06 | 显示全部楼层
加我qq:409946461 随时技术支持

使用特权

评论回复
 楼主 | 2020-5-27 08:54 | 显示全部楼层
martinhu 发表于 2020-5-25 11:31
如果你使用的是CMSIS DAP,那么就不要选Jlink呀,选CMSIS DAP工具

我试了多个选项,都没查到设备

使用特权

评论回复
| 2020-5-27 09:53 | 显示全部楼层
vinci25031891 发表于 2020-5-27 08:54
我试了多个选项,都没查到设备

你是不是数据线不好?用了充电宝的充电线?

使用特权

评论回复
| 2020-5-27 10:08 | 显示全部楼层
如果你电脑端都能看到端口名字了,那么只要连上USB数据线,就可以了
或者你发一下自己板子的连接照片
111555ecdcba15be0a.png
891215ecdcb892d26a.png
755885ecdcb7b20ed2.png

使用特权

评论回复
| 2020-5-27 10:10 | 显示全部楼层
vinci25031891 发表于 2020-5-27 08:54
我试了多个选项,都没查到设备

有可能的话,换台电脑,试试;或者换一个操作系统。有时候,安装驱动,装上无反应,就看不见设备。

使用特权

评论回复

评论

tianqi911 2020-5-28 14:55 回复TA
@martinhu :文档上说是不用,但有些客户的电脑是没法用的,搜不到设备。win7 win8 win10都有这个现象。 
martinhu 2020-5-28 11:27 回复TA
新版的DAP仿真器使用的是华大自己的F460芯片,win7或win10好像不需要安装驱动,直接可以用了 
 楼主 | 2020-5-27 15:03 | 显示全部楼层
本帖最后由 vinci25031891 于 2020-5-27 15:05 编辑
martinhu 发表于 2020-5-27 09:53
你是不是数据线不好?用了充电宝的充电线?

从华大代理商那里拿的debugger带的usb线  。 有时都怀疑是不是开发板有问题。但是这个开发板也是代理商邮寄的

使用特权

评论回复
| 2020-5-27 17:03 | 显示全部楼层
需要可以传输数据的线。只能供电的usb线好像没用

使用特权

评论回复
| 2020-6-8 15:25 | 显示全部楼层
升级一下呢

使用特权

评论回复
| 2020-6-8 15:25 | 显示全部楼层
是不是需要单独供电啊

使用特权

评论回复
| 2020-6-8 15:25 | 显示全部楼层
小概率数据线的问题

使用特权

评论回复
扫描二维码,随时随地手机跟帖
您需要登录后才可以回帖 登录 | 注册

本版积分规则

我要发帖 投诉建议 创建版块 申请版主

快速回复

您需要登录后才可以回帖
登录 | 注册
高级模式

论坛热帖

在线客服 快速回复 返回顶部 返回列表