搜索

MOS开关干扰到LDO输出

[复制链接]
392|28
 楼主 | 2021-1-15 17:21 | 显示全部楼层 |阅读模式
自己画的BLDC驱动板,正常情况下1117输出3.3V很平稳。但单片机只要一输出PWM控制mos(频率18K),1117的输出就会有和PWM频率差不多的尖峰毛刺。推测应该是地没有处理好,地的噪声被带到了LDO。用示波器探得MOS的DS有一点开通和关断振铃,将mos栅极电阻增大,情况有所好转。有好的方法彻底去除这些干扰吗?试了1117输入输出加大电容和陶瓷;MOS的DS加RC,都没有好转。
更奇葩的是一个设为输入模式内部上拉的IO,电平直接被干扰成锯齿波了。。。
1117输出干扰.jpg DS上升波形.jpg DS波形.jpg 上拉输入IO被干扰成锯齿波.jpg 原理图2.png 原理图.png PCB.png PCB2.png

使用特权

评论回复

相关帖子

 楼主 | 2021-1-15 17:24 | 显示全部楼层
@tianxj01 按照您的教程帖子学的,打算做无感驱动。可以帮忙看看嘛

使用特权

评论回复
| 2021-1-15 21:01 | 显示全部楼层
LDO加强退耦能力。
Image_269.png

使用特权

评论回复

评论

king5555 2021-1-16 18:36 回复TA
@xiaoyuanguo :即使没改善,对于LDO的输入端还是得如此处理。LDO的一大缺点就是无法承受急促的上电,容易在其输出端出现突波而其负载过压。在此你示波器测量的地线夾在不同位置,所显示的波形会有不同。要全面的优化和改善,必须有恰当的布线,尤其是各个地线的布线,同时要有电源退耦的机制。三组MOS管的电源旁路大电容,应靠近连结于MOS管回路,这是重点。 
xiaoyuanguo 2021-1-16 10:49 回复TA
试了加1K串100uf电解并没有明显改善,我觉得是mos驱动的布线问题。只要不控制MOS就没有干扰,而且控制mOS时采样电阻端的波形有很多尖峰 
| 2021-1-15 22:55 | 显示全部楼层
关注,单片机地脚底下好像有线,地脚飞个磁珠到地不知道会不会好点

使用特权

评论回复
| 2021-1-16 08:34 | 显示全部楼层
先把LDO和MOS的电源分开再分析其他问题,先排除干扰是通过电源绕过去的

使用特权

评论回复
| 2021-1-16 08:35 | 显示全部楼层
关断振铃有可能是关断器件没有快速泄放,一般在栅极驱动电阻两端并一个肖特基二极管。另外干扰大的话,电源间会使用磁珠。

使用特权

评论回复
| 2021-1-16 10:22 | 显示全部楼层
24V 供电的是蓄电池吗?
电机功率多大?
被干扰的,内部上拉的IO具体是哪个节点?

使用特权

评论回复

评论

xiaoyuanguo 2021-1-16 10:45 回复TA
U5右边的R31 32 33 
xiaoyuanguo 2021-1-16 10:45 回复TA
供电是开关电源,没有带载,只是输出PWM控制MOS开关就会有干扰。U5边上的那三个电阻,是比较器LM339检测各相反电动势过零的输出,连接单片机IO;设置为内部上拉,测试的就是这三个点 
| 2021-1-16 11:34 | 显示全部楼层
U5 大概是 LM339,在 PCB 图里看到的,原理图上没看到。
这三个上拉电阻按理应该是接到某个电源,不过看起来像是直接进了单片机……
这部分原理图能晒晒吗?

另外能不能在空载和加载(单片机输出 PWM 驱动电机)两种下,
用示波器测量 24V、12V 和 3V 的电源情况,晒出来看看?

使用特权

评论回复

评论

xiaoyuanguo 2021-1-18 08:49 回复TA
@xiaoyuanguo :电源是有尖的脉冲,HC变成了锯齿波,HB和HA还好 
xiaoyuanguo 2021-1-18 08:47 回复TA
@Jack315 :电源在mos管没有开关动作时,波形都很平稳,去掉r31r32r33,测到的hahbhc也很平稳;首楼的上升和下降沿,就是MA,MB,MC点的波形。在MOS工作(开关)时,电源和HA HB HC就变成了一楼的锯齿波 
Jack315 2021-1-16 14:05 回复TA
@xiaoyuanguo :这个问题说不好。先确定电源没问题后再来看 Ma、Mb、Mc 与 ha、hb、hc 各点波形究竟是什么情况。 
xiaoyuanguo 2021-1-16 11:57 回复TA
那个是限流电阻,单片机是内部上拉的。339是开漏,这个锯齿波只能是MUC的供电有波动才会形成的吧 
xiaoyuanguo 2021-1-16 11:55 回复TA
发在楼下了 
xiaoyuanguo 2021-1-16 11:48 回复TA
好的,下午测,先把原理图发在楼下;这个就是参照t先生(tianxj01)的帖子做的,下午测了放波形 
 楼主 | 2021-1-16 11:53 | 显示全部楼层
7150660026349224df.png

使用特权

评论回复
| 2021-1-16 13:18 | 显示全部楼层
3.3V电源,连个容量大一点的电容都看不到,这么抠嘛?

使用特权

评论回复

评论

lfc315 2021-1-16 14:23 回复TA
@xiaoyuanguo :24V 12V 3.3V电源都稳定吗?把MOS的G极47R电阻先去掉,不带MOS管是什么情况;再试试把EG2132拿掉,又是什么情况? 
xiaoyuanguo 2021-1-16 13:24 回复TA
试过了,加了470uf都还是有干扰 
| 2021-1-16 18:12 | 显示全部楼层
死区时间是哪部分控制的?

使用特权

评论回复

评论

xiaoyuanguo 2021-1-18 08:49 回复TA
2133自带了死区,所以这里单片机没有做死区互补 
| 2021-1-16 18:25 | 显示全部楼层
地线走线很重要,大电流回路的GND要单独走线,单独回路,不要不分割就大面积铺地。
另外,示波器接地和测试方法不对也会带入干扰。

使用特权

评论回复
| 2021-1-16 19:22 | 显示全部楼层
IO口的锯齿波,也可能是339有动作而导致的呢?
不然如果是3.3V电源被拉低那么多,单片机都复位了吧。

使用特权

评论回复
| 2021-1-17 10:13 | 显示全部楼层
LDO  1117的位置设置的有点不合理,应该就近靠近被驱动负载,并且地线也尽量靠近负载。输入12V稍长是没问题的。你这里输出过长,纹波应该是这样测量到的,而且,非常怀疑测量过程并不准确,靠近单片机将示波器GND和探头接同一个GND点估计你也可能测量出这样的波形。
如果怀疑真正这样波形的供电输入给的单片机,你可以在单片机VCC附近切断3.3V,串联合适的电阻再加退偶解决(图中C4位置切断,串联一个贴片电阻),又单片机和退偶电容的GND接入处理很差,只有一个过孔,这里至少一个过孔群才好。

使用特权

评论回复

评论

xiaoyuanguo 2021-1-18 09:00 回复TA
确实测同一个地也有尖的脉冲;但只要MOS管不开关,就没有任何干扰;而且降低mos的开关速度(增大栅极电阻),干扰会变小;没办法了这版先调程序将就着用,下版再重新布线。。。 
| 2021-1-19 08:43 | 显示全部楼层
很有可能是测量问题,  要用示波器的弹簧地线, 避免共地干扰.  一般的只要CPU的3.3V没有被拉低到复位值, 问题不大

使用特权

评论回复
扫描二维码,随时随地手机跟帖
您需要登录后才可以回帖 登录 | 注册

本版积分规则

我要发帖 我要提问 投诉建议 申请版主

快速回复

您需要登录后才可以回帖
登录 | 注册
高级模式

论坛热帖

关闭

热门推荐上一条 /6 下一条

在线客服 快速回复 返回顶部 返回列表