搜索

[KungFu8位 MCU] 4158波形不干净,文波好大

[复制链接]
223|18
 楼主 | 2021-3-17 21:15 | 显示全部楼层 |阅读模式
最近玩4158的PWM,用示波器看波形,不管是低电平还是高电平,都有文波,有知道怎么回事的么?而且2104S的自举电压也举不起来,举起来一瞬间就降下去了,
4f91be89569471db532b5b7e4dcc00b.jpg

使用特权

评论回复
| 2021-3-18 09:10 | 显示全部楼层
是不是寄存器哪里设置有问题

使用特权

评论回复
| 2021-3-18 11:35 | 显示全部楼层
先用官方的开发板和官方的例子测试看看

使用特权

评论回复
 楼主 | 2021-3-18 22:09 | 显示全部楼层
两只袜子 发表于 2021-3-18 09:10
是不是寄存器哪里设置有问题

纹波的问题应该是没什么,可能是示波器的问题,因为我用示波器自己的校准方波测试也是有纹波,但是自举电压就是上不去

使用特权

评论回复
 楼主 | 2021-3-18 22:09 | 显示全部楼层
wanduzi 发表于 2021-3-18 11:35
先用官方的开发板和官方的例子测试看看

应该是示波器的问题

使用特权

评论回复
| 2021-3-19 08:46 | 显示全部楼层
波形测量,第一条:先要保证探头的地与被测点的电流环路长度最短。示波器的探头都有送一个弹簧,这个是专用于测量时接地的(取下探头的钩子,套在示波器的探头钩子卡位的接地环上),可保证输入端的电流环路最短,避开地线引入的干扰,实测测试中,出现如图所示的尖峰,100%是探头自身引入的。板子的地线问题。你可以试验一下,找2个不同位置的接地点测试(距离越远,尖峰幅值越大),绝对一样出现楼上的尖峰波形。别想当然的认为地就是100%的0V,无纹波。

使用特权

评论回复
| 2021-3-19 08:48 | 显示全部楼层
hjl2832 发表于 2021-3-19 08:46
波形测量,第一条:先要保证探头的地与被测点的电流环路长度最短。示波器的探头都有送一个弹簧,这个是专用 ...

特别是在进行开关电源设计调试时,测量纹波,不能随意将探头接入一个接地点测量。

使用特权

评论回复
| 2021-3-22 20:21 | 显示全部楼层
看来楼主找到问题了。

使用特权

评论回复
| 2021-3-25 10:31 | 显示全部楼层
可以看看 线的问题,是不是线有些长或者有些问题呢?

使用特权

评论回复
| 2021-3-25 10:31 | 显示全部楼层
看看寄存器之类的,是不是那块没配置好?

使用特权

评论回复
| 2021-3-25 10:36 | 显示全部楼层
示波器不错奥 哈哈哈

使用特权

评论回复
| 2021-3-25 10:37 | 显示全部楼层
跑一下官方的demo试试呢 看看是不是程序问题

使用特权

评论回复
| 2021-3-30 15:08 | 显示全部楼层
示波器的线没接好吗

使用特权

评论回复
| 2021-4-1 15:58 | 显示全部楼层
我感觉是不是代码的问题了?

使用特权

评论回复
| 2021-4-1 17:23 | 显示全部楼层
官方的开发板的纹波也是这么大吗?
还是?

使用特权

评论回复
| 2021-4-2 07:57 | 显示全部楼层
纹波大和供电有关系

使用特权

评论回复
 楼主 | 2021-4-6 11:15 | 显示全部楼层
里面有晴雨 发表于 2021-4-1 17:23
官方的开发板的纹波也是这么大吗?
还是?

应该是线束的问题,和板子无关

使用特权

评论回复
 楼主 | 2021-4-6 11:16 | 显示全部楼层
单片小菜 发表于 2021-4-1 15:58
我感觉是不是代码的问题了?

应该是线束的问题,因为我用示波器自己的校验方波测试也有纹波

使用特权

评论回复
| 2021-4-6 11:20 | 显示全部楼层
示波器的精度不高吧。
我感觉示波器的问题。

使用特权

评论回复
扫描二维码,随时随地手机跟帖
您需要登录后才可以回帖 登录 | 注册

本版积分规则

我要发帖 我要提问 投诉建议 申请版主

快速回复

您需要登录后才可以回帖
登录 | 注册
高级模式

论坛热帖

在线客服 快速回复 返回顶部 返回列表