[技术问答]

AC7801电机开发板的串口打印问题

[复制链接]
1519|15
手机看帖
扫描二维码
随时随地手机跟帖
zhenweiliu|  楼主 | 2022-8-24 16:19 | 显示全部楼层 |阅读模式
本帖最后由 zhenweiliu 于 2022-8-24 16:23 编辑

  通过一个简单的程序,调试完成后,就想着通过串口打印试试,结果就发现了一些问题。 程序是通过按键改变led闪烁频率,调试都没问题,关键是我通过printf输出一个数据,出现问题了,用了两个串口调试助手都没有收到数据,也没有任何显示(端口,波特率设置都没问题),附图,求助,求助,到底是哪里出现了问题啊(附程序【IAR】)
509616305dc611b2d4.png 260096305dc6f25c16.png 962316305dc85331a7.png 647696305dc7c504a5.png 404216305dc94d362c.png 182056305dfffae38e.png
这个程序有点大放不上来,给个链接  
http://bbs.**/thread-1215482-1-1.html
求助,求助,怎么解决这个串口打印的问题

使用特权

评论回复
zhenweiliu|  楼主 | 2022-8-24 16:19 | 显示全部楼层
http://bbs.**/thread-1215482-1-1.html

使用特权

评论回复
zhenweiliu|  楼主 | 2022-8-24 16:20 | 显示全部楼层
bbs.**

使用特权

评论回复
问天少年| | 2022-8-24 17:01 | 显示全部楼层
输出端口和硬件端口是否一致

使用特权

评论回复
Q1258053837| | 2022-8-30 19:07 | 显示全部楼层
确认一下CH340的Rx Tx电阻是否焊接了

使用特权

评论回复
永远不停| | 2022-9-1 17:50 | 显示全部楼层
代码里默认使用打印口是UART2(PB9/PB10),这个电机板上的USB口用的是UART1,与程序里的没对应上,所以没有打印出来

使用特权

评论回复
tpgf| | 2022-9-4 16:11 | 显示全部楼层
楼主想要打印到哪里去呢

使用特权

评论回复
nawu| | 2022-9-4 16:17 | 显示全部楼层
通过串口发送到上位机上来是吗

使用特权

评论回复
aoyi| | 2022-9-4 16:42 | 显示全部楼层
设置的波特率是否一致啊

使用特权

评论回复
zljiu| | 2022-9-4 16:51 | 显示全部楼层
用示波器看一下线上的波形

使用特权

评论回复
gwsan| | 2022-9-4 16:59 | 显示全部楼层
首选确认是否已经发送出来了数据

使用特权

评论回复
tfqi| | 2022-9-4 17:07 | 显示全部楼层
串口线接错了吗

使用特权

评论回复
saservice| | 2022-9-4 22:05 | 显示全部楼层
使用keil开发的话,需要虚着呢microusb

使用特权

评论回复
hudi008| | 2022-9-5 14:29 | 显示全部楼层
这个重定义一下吧

使用特权

评论回复
burgessmaggie| | 2022-9-5 15:29 | 显示全部楼层
串口有问题吗

使用特权

评论回复
Henryko| | 2022-9-9 19:29 | 显示全部楼层
通过串口发送到上位机上来是吗

使用特权

评论回复
发新帖 我要提问
您需要登录后才可以回帖 登录 | 注册

本版积分规则