[STM32F1]

关于锂电池电阻分压测电量的问题

[复制链接]
244|14
手机看帖
扫描二维码
随时随地手机跟帖
qq5782098|  楼主 | 2022-9-22 10:24 | 显示全部楼层 |阅读模式
本帖最后由 qq5782098 于 2022-9-22 17:26 编辑

10000mah,3.7V锂电池。工作电流为300ma
forum.jpg
分压电路
采样点实际电压与采样计算电压相差60mv
测量出来的电量精度不高,不能很好的反应电压跟电量的关系
想要实现,从0%~100%的显示效果
疑问:
1. 导致不精确的原因是什么

自己猜测:
1. 测量算法没做好
2. 大电流情况下,不合适用电阻分压方案
3. 电路设计有问题

有小伙伴知道是什么原因吗?
或者有别的低成本的方案介绍?







1663811725148.jpg

使用特权

评论回复
一周一天班| | 2022-9-22 16:49 | 显示全部楼层
阻抗过大

使用特权

评论回复
qq5782098|  楼主 | 2022-9-22 17:25 | 显示全部楼层

你觉得多少合适呢?100K50K分压?因为我看到也有人用1M做分压的,主要是想降低待机功耗。

使用特权

评论回复
xch| | 2022-9-22 17:40 | 显示全部楼层
使用微功耗运放缓冲一下分压

使用特权

评论回复
xch| | 2022-9-22 17:40 | 显示全部楼层
https://www.ti.com/product/TLV8811

使用特权

评论回复
xch| | 2022-9-22 17:56 | 显示全部楼层
37154632c313840664.png

使用特权

评论回复
xch| | 2022-9-22 18:04 | 显示全部楼层
50718632c33465d4e6.png

使用特权

评论回复
玄德| | 2022-9-22 18:07 | 显示全部楼层

两件事分开,把前面断开,先看 AD 是否准确。
如果 AD 准确,那就是前面分压电阻太大,后面的负载电流影响分压值。


使用特权

评论回复
ughbss| | 2022-9-22 18:59 | 显示全部楼层
1,AD不准很可能是输入阻抗和参考电压的问题
2,电压采样方式做电量本身就不准,和电池内阻,充放电电流,电池放电曲线,老化程度都有关,想做到1%根本不可能的
     现在大部分实现方案是库伦积分+电压修正+其它算法修正

使用特权

评论回复
wangshujun| | 2022-9-23 08:51 | 显示全部楼层
把104电容挪到r119后面看看

使用特权

评论回复
qq5782098|  楼主 | 2022-9-23 10:46 | 显示全部楼层

这个我后面再试一下,目前电路是这样的。只能在这个基础上分析原因,后面改了电路试下这个方案。

使用特权

评论回复
qq5782098|  楼主 | 2022-9-23 10:52 | 显示全部楼层
ughbss 发表于 2022-9-22 18:59
1,AD不准很可能是输入阻抗和参考电压的问题
2,电压采样方式做电量本身就不准,和电池内阻,充放电电流, ...

在AD准确的前提下,分压方式一般能做到电量的多少精度呢?

使用特权

评论回复
评论
ughbss 2022-9-29 13:09 回复TA
纯电压检测我们一般是做3段/4段电量显示 
qq5782098|  楼主 | 2022-9-23 10:54 | 显示全部楼层
玄德 发表于 2022-9-22 18:07
两件事分开,把前面断开,先看 AD 是否准确。
如果 AD 准确,那就是前面分压电阻太大,后面的负载电流影响 ...

前面断开不就悬空了吗?

使用特权

评论回复
评论
玄德 2022-9-23 11:10 回复TA
断开以后,另外加已知的电压 
发新帖 我要提问
您需要登录后才可以回帖 登录 | 注册

本版积分规则