[LKS32 硬件]

jlink无法识别芯片

[复制链接]
277|12
手机看帖
扫描二维码
随时随地手机跟帖
kmitty|  楼主 | 2023-1-21 20:12 | 显示全部楼层 |阅读模式
本帖最后由 kmitty 于 2023-1-28 14:00 编辑

我用的是正版jlink edu 版本,v11,可以确认jlink是ok的,驱动没有问题,连接其他芯片,可以正常调试。
目前jlink 可以输出5V,调换CLK和DIO线也没用,例程是凌鸥官方例程,也可以正常编译

求助
    还有什么其他解决思路吗
Snipaste_2023-01-28_14-00-04.png

使用特权

评论回复
kmitty|  楼主 | 2023-1-21 20:16 | 显示全部楼层
如图所示
Snipaste_2023-01-21_20-15-51.png

使用特权

评论回复
一路寻你| | 2023-1-23 19:50 | 显示全部楼层

先确定硬件是否正常,如果是demo板重点看下DIO、CLK接口和芯片引脚是否连接正常,如果硬件是自己设计的,重点查下原理图和官网提供的是否一致(主要是引脚布局,如引脚顺序对应错位等等);有条件的可以换一个硬件试下。

使用特权

评论回复
cooldog123pp| | 2023-1-27 22:58 | 显示全部楼层
首先看下jlink是否支持你要识别的芯片,好多国产芯片不支持,其次看看你sw模式下几根线对了不,mcu供电了吗。

使用特权

评论回复
单片小菜| | 2023-1-28 10:06 | 显示全部楼层
检查一下电路,看看电压是不是正确吧。

使用特权

评论回复
classroom| | 2023-1-28 10:16 | 显示全部楼层
先排除一下硬件设计是否有BUG吧

使用特权

评论回复
classroom| | 2023-1-28 10:17 | 显示全部楼层
再检查一下你的芯片供电是否对头!

使用特权

评论回复
kmitty|  楼主 | 2023-1-28 13:54 | 显示全部楼层
classroom 发表于 2023-1-28 10:16
先排除一下硬件设计是否有BUG吧

用的是凌鸥的开发板,应该没问题吧

使用特权

评论回复
kmitty|  楼主 | 2023-1-28 13:54 | 显示全部楼层
classroom 发表于 2023-1-28 10:17
再检查一下你的芯片供电是否对头!

检查过了,5V供电正常,指示灯也亮了

使用特权

评论回复
kmitty|  楼主 | 2023-1-28 13:57 | 显示全部楼层
一路寻你 发表于 2023-1-23 19:50
先确定硬件是否正常,如果是demo板重点看下DIO、CLK接口和芯片引脚是否连接正常,如果硬件是自己设计的, ...

感谢回复,板子是凌鸥的demo板,硬件本身和硬件连接应该没有问题,5V的LED灯可以正常亮起

使用特权

评论回复
yungjiaxi| | 2023-2-2 09:26 | 显示全部楼层
试下5KHZ能识别码,5KHZ能识别应该是驱动不足吧

使用特权

评论回复
江南星语| | 2023-2-3 10:22 | 显示全部楼层
如果仔细检查了不是硬件问题(可以找一个别人的正确工程验证一下),可以试试最开始在MDK中选择仿真器、下载器的时候,有个弹出让选择芯片类型,要选择cortex-cm0 (对于081来说),不要直接关闭或选其它,参考图片
2023-02-03_101707.png

使用特权

评论回复
kmitty|  楼主 | 2023-2-7 09:35 | 显示全部楼层
本帖最后由 kmitty 于 2023-2-7 09:36 编辑

解决了,换了个盗版的jlink就可以识别芯片了。但是烧录不稳定,10次有7,8次是失败的,尝试降低了频率,从5Mhz,到2kHZ,没有什么改善,测量供电电平4.9V左右,烧录前还需要复位一下

使用特权

评论回复
发新帖 我要提问
您需要登录后才可以回帖 登录 | 注册

本版积分规则