搜索

双运放V-I电路输出波形问题

[复制链接]
2194|24
arm菜鸟人|  楼主 | 2014-4-13 11:23 | 显示全部楼层 |阅读模式

使用双运放的电压转电流电路,如附图。

输入信号为单一频率的正弦信号。仿真时是正常的。

实际过程中,输入信号频率小于200Hz时,波形中混有其他成分,有一个周期大概是50ms的信号,而且波形“失真?”,可见相应附图。
在频率大于250Hz时,输出波形正常,为同频正弦波信号。见附图500Hz输出信号。

请问50ms的信号是怎么产生的?怎么去除呢?为什么在频率小于200Hz的时候才产生,大于250Hz时不出现这一现象呢?

欢迎大家积极讨论。
100Hz-三角波.jpg
100Hz输出-2.jpg
50Hz输出.jpg
100Hz输出.jpg
200Hz输出.jpg
500Hz输出.jpg
OPA2364 VtoI 恒流源电路.jpg

相关帖子

zyj9490| | 2014-4-13 12:50 | 显示全部楼层
示波器打到DC输入,看输入,输出的电位再分析

使用特权

评论回复

评分

参与人数 1威望 +2 收起 理由
arm菜鸟人 + 2
arm菜鸟人|  楼主 | 2014-4-13 14:33 | 显示全部楼层
zyj9490 发表于 2014-4-13 12:50
示波器打到DC输入,看输入,输出的电位再分析

交直流耦合电位差不多,
看图片“100Hz输出”就是直流耦合的。

使用特权

评论回复
zyj9490| | 2014-4-13 15:04 | 显示全部楼层
可以加大耦合电容,试下,

使用特权

评论回复

评分

参与人数 1威望 +2 收起 理由
arm菜鸟人 + 2
arm菜鸟人|  楼主 | 2014-4-13 15:07 | 显示全部楼层
zyj9490 发表于 2014-4-13 15:04
可以加大耦合电容,试下,

一开始就是加的2200pF 的CBB电容。

使用特权

评论回复

评论

zyj9490 2014-4-13 15:29 回复TA
全部电容都要加大, 
zyj9490 2014-4-13 15:28 回复TA
电介电容+CBB的方式加 
zyj9490 2014-4-13 15:27 回复TA
太小了, 
zyj9490| | 2014-4-13 15:13 | 显示全部楼层
在频率下端,相位偏移必须考量耦合电容的影响。

使用特权

评论回复

评分

参与人数 1威望 +2 收起 理由
arm菜鸟人 + 2
arm菜鸟人|  楼主 | 2014-4-13 15:25 | 显示全部楼层
zyj9490 发表于 2014-4-13 15:13
在频率下端,相位偏移必须考量耦合电容的影响。

不懂。

使用特权

评论回复
zyj9490| | 2014-4-13 15:26 | 显示全部楼层
在A2的反馈环节路,加RC并联网络进行校正。在反相端与输出端之间加,把原来的直接连接打断。

使用特权

评论回复
zyj9490| | 2014-4-13 15:33 | 显示全部楼层
arm菜鸟人 发表于 2014-4-13 15:25
不懂。

我怀疑有牵引自激存在。可以仿真下幅频,相频,是不是有临界点。因为大环是正反馈。靠局部负反馈进行稳定的。

使用特权

评论回复

评分

参与人数 1威望 +4 收起 理由
arm菜鸟人 + 4
arm菜鸟人|  楼主 | 2014-4-13 16:14 | 显示全部楼层
zyj9490 发表于 2014-4-13 15:33
我怀疑有牵引自激存在。可以仿真下幅频,相频,是不是有临界点。因为大环是正反馈。靠局部负反馈进行稳定 ...

确实有产生自激的可能。
不过仿真时是正常的。
刚仿真贴上其幅相频特性,没有突变点。
幅频特性.jpg
相频.jpg

使用特权

评论回复
arm菜鸟人|  楼主 | 2014-4-13 16:15 | 显示全部楼层
zyj9490 发表于 2014-4-13 15:26
在A2的反馈环节路,加RC并联网络进行校正。在反相端与输出端之间加,把原来的直接连接打断。 ...

嗯,试一试。
谢谢你的关注!

使用特权

评论回复
鸟鸟| | 2014-4-13 17:39 | 显示全部楼层

使用特权

评论回复

评分

参与人数 1威望 +1 收起 理由
arm菜鸟人 + 1 感谢关注!
湖北泽翔| | 2014-4-13 19:41 | 显示全部楼层

使用特权

评论回复

评分

参与人数 1威望 +1 收起 理由
arm菜鸟人 + 1 赞一个!
湖北泽翔| | 2014-4-13 19:42 | 显示全部楼层

使用特权

评论回复
湖北泽翔| | 2014-4-13 19:43 | 显示全部楼层

使用特权

评论回复
xygyszb| | 2014-4-14 13:10 | 显示全部楼层
频率低的时候出问题,是不是耦合电容的容值小了。加大耦合电容容值试试。
或者可以将耦合电容焊接0R电阻试试。

使用特权

评论回复

评分

参与人数 1威望 +4 收起 理由
arm菜鸟人 + 4
arm菜鸟人|  楼主 | 2014-4-14 15:47 | 显示全部楼层
xygyszb 发表于 2014-4-14 13:10
频率低的时候出问题,是不是耦合电容的容值小了。加大耦合电容容值试试。
或者可以将耦合电容焊接0R电阻试 ...

谢谢关注。

使用特权

评论回复
arm菜鸟人|  楼主 | 2014-4-14 15:56 | 显示全部楼层
再焊了一块 V-I电路板,发现输出信号正常。
回想第一块板子在焊接的时候有一个器件(电阻?电容?)的焊盘掉了,直接焊上去的,不知是否是这个引起的。还有,就是几个器件的封装画小了(耦合电容)。后来继续测试第一块的时候,发现高频率的输出也不正常了,波形噪声很大。

整体调试发现,V-I输出负载阻抗低了点,大概只有1KΩ。
测试时发现线性度也不是很好,即恒流特性不佳。与仿真结果相差较大。

附图是负载与输出电压(有效值)之间的关系,横轴是电压,纵轴是负载电阻。
恒流源输出特性.jpg

使用特权

评论回复
zyj9490| | 2014-4-14 18:37 | 显示全部楼层
本帖最后由 zyj9490 于 2014-4-14 18:39 编辑
arm菜鸟人 发表于 2014-4-14 15:56
再焊了一块 V-I电路板,发现输出信号正常。
回想第一块板子在焊接的时候有一个器件(电阻?电容?)的焊盘 ...

RL<<R/2,才是恒流.量RS二端是不是恒压.是的话,这个电路工作正常的,是后面电路的问题.

使用特权

评论回复

评分

参与人数 1威望 +3 收起 理由
arm菜鸟人 + 3
arm菜鸟人|  楼主 | 2014-4-15 08:55 | 显示全部楼层
zyj9490 发表于 2014-4-14 18:37
RL

这个R 是匹配网络的电阻 还是?

使用特权

评论回复
扫描二维码,随时随地手机跟帖
您需要登录后才可以回帖 登录 | 注册

本版积分规则

我要发帖 我要提问 投诉建议 申请版主

快速回复

您需要登录后才可以回帖
登录 | 注册
高级模式

本版热帖

本版活跃用户

优质原创写原创,赢大奖

编辑推荐

  • 1 wolfe_yu 得到打赏 ¥170.00
  • 2 小叶三千 得到打赏 ¥160.00
  • 3 最美葫芦娃 得到打赏 ¥155.00
  • 4 呐咯密密 得到打赏 ¥135.00
  • 5 hk386 得到打赏 ¥100.00
  • 6 laocuo1142 得到打赏 ¥85.00
  • 7 木野臻 得到打赏 ¥60.00
  • 8 ezcui 得到打赏 ¥60.00
  • 9 wzx1994 得到打赏 ¥60.00
  • 10 年轻的国王 得到打赏 ¥60.00
在线客服 快速回复 返回顶部 返回列表