打印

[USB 控制器] CY68013串口 接收和发送的数据不一致

[复制链接]
340|29
跳转到指定楼层
楼主
CY68013串口 接收和发送的数据不一致
沙发
| 2018-1-7 14:53 | 只看该作者
检查过 波特率 和方式设置了吗?
板凳
 楼主 | 2018-1-7 14:55 | 只看该作者
都没有问题
地板
| 2018-1-7 14:58 | 只看该作者
光数据不对 ?
5
 楼主 | 2018-1-7 15:00 | 只看该作者
不仅是数据不对 位数也多了
6
| 2018-1-7 15:03 | 只看该作者
68013默认使用的是串口1,其实68013的串口跟51的串口设置是一模一样的
7
 楼主 | 2018-1-7 15:08 | 只看该作者
有代码吗?
8
| 2018-1-7 15:10 | 只看该作者
EA=0;TMOD&=0x0F;TMOD|=0x20;SCON1=0x50; PCON|=0x80;TH1=-fosc/384/bps;ES1=1; TR1=1; REN=1;EA=1
9
 楼主 | 2018-1-7 15:13 | 只看该作者

能讲讲吗?
10
| 2018-1-7 15:23 | 只看该作者

这是初始化,fosc和bps分别是晶振和波特率
11
 楼主 | 2018-1-7 15:26 | 只看该作者
哦,这样啊
12
| 2018-1-7 15:29 | 只看该作者
设置好了之后,只需要在中断7中读取SBUF1和写入SBUF1就可以完成接收和发送的工作了
13
 楼主 | 2018-1-7 15:31 | 只看该作者

有需要注意的地方吗?
14
| 2018-1-7 15:34 | 只看该作者
前提是你的上位机的串口参数要对号!
15
 楼主 | 2018-1-7 15:37 | 只看该作者

这个是我的程序 大家给看一下 设置有没有问题呢
BYTE  temp_data;
BYTE  flag;
void REG_Init()
{
      CPUCS = 0x10; //48Mhz
      CKCON = (CKCON&(~bmSTRETCH)) | 1;
}
void SerialPort_Init()
{
      TMOD = (TMOD & 0x0F) | 0x20;   // 定时器1工作方式2,自动重载  
    CKCON |= 0x10;  //T1M = CLKOUT/4
     EICON |= 0x80;  //设置SMOD1=1,波特率加倍  
    SCON1 = 0x50;  //串行口1工作方式1,10位异步收发,REN=0,允许接收。RI1=0,TI1=0
   TH1  = 0xD9;      //定时器1的初值      
  ES1 = 1;     //允许串口1中断
    TR1 = 1;
     EA = 1;
}
void Serial_SendChar(BYTE source)
{
      SBUF1 = source;
      while(TI1 == 0);
      TI1 = 0;
}
void Serial_Interrupt1() interrupt 7
{        
      if(RI1 == 1)
      {
          RI1 = 0;
          temp_data = SBUF1;
          flag = 1;
      }
}     

void main(void)
{
      REG_Init();
      SerialPort_Init();
      EA = 1;
      while(1)
      {
           if(flag==1)
          {
               flag=0;
              Serial_SendChar(temp_data);
          }
      }
}
16
| 2018-1-7 15:39 | 只看该作者
你的时钟是怎么设置的呢?
17
| 2018-1-7 15:43 | 只看该作者
有个选择时钟的寄存器,好像bit6就是选择是36M还是48M,就是根据这个来看的!寄存器的名字就是IFCONFIG。
18
| 2018-1-7 15:45 | 只看该作者
你把你的PCON|=0x80;然后我觉得你的TH1有问题,你如果波特率是9600的话,按照楼上的算法算出来就是TH1=-13,但是你的TH=217,你写成TH1=-13,试试看!
19
| 2018-1-7 15:47 | 只看该作者
触摸电阻异常
20
 楼主 | 2018-1-7 15:49 | 只看该作者

谢谢。
PCON是设置串口0的,我用的是串口1。
之前线接的有问题,改完后可以收发数据了,但是收到的数据不对。
扫描二维码,随时随地手机跟帖
*滑动验证:
您需要登录后才可以回帖 登录 | 注册 手机登录

本版积分规则

快速回复

您需要登录后才可以回帖
登录 | 注册 手机登录
高级模式

论坛热帖

分享 快速回复 返回顶部 返回列表