[USB 控制器] CY68013串口 接收和发送的数据不一致

[复制链接]
376|29
| 2019-6-22 15:16 | 显示全部楼层

检查过 波特率 和方式设置了吗?

使用特权

评论回复
 楼主 | 2019-6-22 15:19 | 显示全部楼层
都没有问题

使用特权

评论回复
| 2019-6-22 15:22 | 显示全部楼层

光数据不对 ?

使用特权

评论回复
 楼主 | 2019-6-22 15:27 | 显示全部楼层
不仅是数据不对 位数也多了

使用特权

评论回复
| 2019-6-22 15:31 | 显示全部楼层
68013默认使用的是串口1,其实68013的串口跟51的串口设置是一模一样的

使用特权

评论回复
 楼主 | 2019-6-22 15:34 | 显示全部楼层
有代码吗?

使用特权

评论回复
| 2019-6-22 15:40 | 显示全部楼层
EA=0;TMOD&=0x0F;TMOD|=0x20;SCON1=0x50; PCON|=0x80;TH1=-fosc/384/bps;ES1=1; TR1=1; REN=1;EA=1

使用特权

评论回复
 楼主 | 2019-6-22 15:43 | 显示全部楼层
能讲讲吗?

使用特权

评论回复
| 2019-6-22 15:46 | 显示全部楼层
这是初始化,fosc和bps分别是晶振和波特率

使用特权

评论回复
 楼主 | 2019-6-22 15:50 | 显示全部楼层
哦,这样啊

使用特权

评论回复
| 2019-6-22 15:53 | 显示全部楼层
设置好了之后,只需要在中断7中读取SBUF1和写入SBUF1就可以完成接收和发送的工作了

使用特权

评论回复
 楼主 | 2019-6-22 15:58 | 显示全部楼层


有需要注意的地方吗?

使用特权

评论回复
| 2019-6-22 16:00 | 显示全部楼层

前提是你的上位机的串口参数要对号!

使用特权

评论回复
 楼主 | 2019-6-22 16:04 | 显示全部楼层

这个是我的程序 大家给看一下 设置有没有问题呢
BYTE  temp_data;
BYTE  flag;
void REG_Init()
{
      CPUCS = 0x10; //48Mhz
      CKCON = (CKCON&(~bmSTRETCH)) | 1;
}
void SerialPort_Init()
{
      TMOD = (TMOD & 0x0F) | 0x20;   // 定时器1工作方式2,自动重载  
    CKCON |= 0x10;  //T1M = CLKOUT/4
     EICON |= 0x80;  //设置SMOD1=1,波特率加倍  
    SCON1 = 0x50;  //串行口1工作方式1,10位异步收发,REN=0,允许接收。RI1=0,TI1=0
   TH1  = 0xD9;      //定时器1的初值      
  ES1 = 1;     //允许串口1中断
    TR1 = 1;
     EA = 1;
}
void Serial_SendChar(BYTE source)
{
      SBUF1 = source;
      while(TI1 == 0);
      TI1 = 0;
}
void Serial_Interrupt1() interrupt 7
{        
      if(RI1 == 1)
      {
          RI1 = 0;
          temp_data = SBUF1;
          flag = 1;
      }
}     

void main(void)
{
      REG_Init();
      SerialPort_Init();
      EA = 1;
      while(1)
      {
           if(flag==1)
          {
               flag=0;
              Serial_SendChar(temp_data);
          }
      }
}

使用特权

评论回复
| 2019-6-22 16:07 | 显示全部楼层
你的时钟是怎么设置的呢?

使用特权

评论回复
| 2019-6-22 16:10 | 显示全部楼层
有个选择时钟的寄存器,好像bit6就是选择是36M还是48M,就是根据这个来看的!寄存器的名字就是IFCONFIG。

使用特权

评论回复
| 2019-6-22 16:18 | 显示全部楼层
你把你的PCON|=0x80;然后我觉得你的TH1有问题,你如果波特率是9600的话,按照楼上的算法算出来就是TH1=-13,但是你的TH=217,你写成TH1=-13,试试看!

使用特权

评论回复
| 2019-6-22 16:21 | 显示全部楼层

触摸电阻异常

使用特权

评论回复
 楼主 | 2019-6-22 16:25 | 显示全部楼层

谢谢。
PCON是设置串口0的,我用的是串口1。
之前线接的有问题,改完后可以收发数据了,但是收到的数据不对。

使用特权

评论回复
扫描二维码,随时随地手机跟帖
您需要登录后才可以回帖 登录 | 注册

本版积分规则

我要发帖 投诉建议 创建版块 申请版主

快速回复

您需要登录后才可以回帖
登录 | 注册
高级模式

论坛热帖