查看: 718|回复: 8
收起左侧

[技术求助] 在用IAR做cc2650的相关方案开发调试过程中报错

[复制链接]

78

主题

3546

帖子

1万

积分

资深工程师

 楼主| 发表于 2016-8-19 22:32 | 显示全部楼层 |返回版面||阅读模式
如题,该问题的困扰我,也找不到具体的解决办法的,版大家有什么办法的,先谢了

78

主题

3546

帖子

1万

积分

资深工程师

 楼主| 发表于 2016-8-19 22:35 | 显示全部楼层 |返回版面
具体的提示错误信息的是"section placement failure:overcommitted content in[0x00000510-0x00000513]",,这是第一个错误的

78

主题

3546

帖子

1万

积分

资深工程师

 楼主| 发表于 2016-8-19 22:38 | 显示全部楼层 |返回版面
第二个错误差不多,只是后边的地址的变了,变成0x0000058C-0x0000058f,就是一直的找不到原因的,不管怎样想办法的,现在还没解决的,看大家的了
      

556

主题

2万

帖子

8万

积分

版主

发表于 2016-8-20 09:22 | 显示全部楼层 |返回版面
按这个修改试试:
IAR工程->option->General Options -> library configuration ->Library选择full,IAR工程->option->General Options -> library Options->printf formatter选择为large
欢迎进入TI MCU论坛      21ic TI技术交流1群:61549143(已满),  21ic TI技术交流2群:311421422

78

主题

3526

帖子

1万

积分

资深工程师

发表于 2016-8-20 17:20 | 显示全部楼层 |返回版面
这个问题的会不会跟你在IAR的集成开发环境中的设计相关系的呢?

12

主题

183

帖子

549

积分

高级技术员

发表于 2016-8-20 19:02 | 显示全部楼层 |返回版面
应该是超过访问的范围了,就像51中那样,需要间接寻址吧,前面的空间不够了。

25

主题

1345

帖子

4039

积分

中级工程师

发表于 2016-8-21 13:56 | 显示全部楼层 |返回版面
smilingangel 发表于 2016-8-19 22:38
第二个错误差不多,只是后边的地址的变了,变成0x0000058C-0x0000058f,就是一直的找不到原因的,不管怎样 ...

这个问题的我以前倒没见到过的,不过这个问题的在网上也找不到解决办法的

24

主题

1375

帖子

4125

积分

中级工程师

发表于 2016-8-21 17:20 | 显示全部楼层 |返回版面
这个错误多关注的,争取早日解决掉。。
     

0

主题

1

帖子

3

积分

实习生

发表于 2017-9-25 14:28 | 显示全部楼层 |返回版面
特意注册个号码来回答下。查TI官方论坛,说是IAR7.4版本以后可能会出现这个问题,官方例程是7.4的,没有毛病
我7.5 解决方法是:option-->C/C++ Comipiter-->optimizations 中的level 选择high
您需要登录后才可以回帖 登录 | 注册 手机登录

本版积分规则

分享 快速回复 返回顶部 返回列表