[开关电源] TPS54331 24V转12V上电就短路烧掉

[复制链接]
830|37
 楼主 | 2019-11-9 11:45 | 显示全部楼层 |阅读模式
不知道什么原因,一上电学生电源就显示短路,断电测试TPS54331 输出和GND短路 输入和GND短路,实在是不知道什么原因,感觉版图画的也差不多和推荐电路一样,求大神帮忙看下,感激不尽!
57315dc635b884b1b.png
67165dc6363f0de1c.png

376515dc635b13a9e3.png

使用特权

评论回复

评论

xch 2019-11-11 21:55 回复TA
@liu4195381 :哪里弄到的TPS54331? 
liu4195381 2019-11-11 09:44 回复TA
@xch :有是有,我用的0630的电感,好像显示电流能过3A,我实际上负载最多1A,所以封装用的小一点的 
xch 2019-11-11 09:42 回复TA
@liu4195381 :电感啥规格? 直觉尺寸很小。15uH@6A 尺寸这么小? SMD的应该有10x10 吧? 
liu4195381 2019-11-11 09:32 回复TA
@xch :不是这个问题,有一个板子没问题,在锂电池上一上电也没有问题,只要负载加一个开发板,锂电池一开,板子也烧,只有把输入电压降低就全好了,可能学生电源稳定好后比锂电池开关浪涌小。 
xch 2019-11-11 09:28 回复TA
@liu4195381 :焊接上了? “有一个板子就没问题” ,可能是焊接好的 
liu4195381 2019-11-11 09:23 回复TA
@xch :隐藏了,实际是和GND连的呢 
xch 2019-11-10 18:13 回复TA
TPS54331DDAR 肚子下有块接地封装,你的PCB上没有。 

相关资料

| 2019-11-9 14:28 | 显示全部楼层
好像这个IC最高28V输入,用在24V输入余量紧张。

使用特权

评论回复
 楼主 | 2019-11-11 09:27 | 显示全部楼层
谢谢大家帮我解决问题,现在我就把输入电压调到16V,直接上电没问题,问题我也没找到,可能就是输入电压到不了28V,学生电源是输出电压先开的,我板子上开关一开,芯片就烧,应该不是学生电源浪涌的问题,即使我用24V锂电池还会出现,只有把输入电压降低就OK了。

使用特权

评论回复

评论

戈卫东 2019-11-11 12:16 回复TA
这样属于电源热插拔,理论浪涌电压是电源电压的2倍。 
 楼主 | 2019-11-9 15:10 | 显示全部楼层
戈卫东 发表于 2019-11-9 14:28
好像这个IC最高28V输入,用在24V输入余量紧张。

电压小点我也试了 一样的效果 但是有一个板子就没问题  

使用特权

评论回复
| 2019-11-9 15:28 | 显示全部楼层
R19是多大?尽量用大点阻值;
D9有没有假焊?

使用特权

评论回复
| 2019-11-9 15:28 | 显示全部楼层
板子不要带电插拔电源也烧么?
(先接好线,在打开试验电源)

使用特权

评论回复
 楼主 | 2019-11-9 15:29 | 显示全部楼层
戈卫东 发表于 2019-11-9 15:28
板子不要带电插拔电源也烧么?
(先接好线,在打开试验电源)

嗯  一上电就显示短路  

使用特权

评论回复
 楼主 | 2019-11-9 15:32 | 显示全部楼层
lfc315 发表于 2019-11-9 15:28
R19是多大?尽量用大点阻值;
D9有没有假焊?

R19 510K   R18  51K   最开始焊过一个板子  当时R18 R19 没有焊接  上电没问题  之后给TX2负载供电 一上电 我的TPS54331 就烧了  今天新焊了一个板子 R19 R18  焊接了电阻  没接负载直接上电就短路烧

使用特权

评论回复
 楼主 | 2019-11-9 15:37 | 显示全部楼层
本帖最后由 liu4195381 于 2019-11-9 15:38 编辑

这个板子是输出三路  现在单独给TPS5430 输出PWM那里是配置的7V也会出现同样的问题,这个不是直接烧,电压从12V升  到24V就直接烧了

98115dc66cbde0e35.png
263505dc66d090267e.png

使用特权

评论回复
| 2019-11-9 15:50 | 显示全部楼层
买了假货了吧。。。。
TI的IC不至于这么差。。

使用特权

评论回复
 楼主 | 2019-11-9 16:04 | 显示全部楼层
戈卫东 发表于 2019-11-9 15:50
买了假货了吧。。。。
TI的IC不至于这么差。。

说不准  实在是找不到原因  焊接没问题

使用特权

评论回复

评论

chenxuzhou66 2019-11-19 11:16 回复TA
你哪里采购的呢 
| 2019-11-9 16:32 | 显示全部楼层
看了数据手册以及官方推荐的电路,你这个Vsense电压设计的应该有问题,在1.221V左右才是对的。
800915dc67960b663b.png

使用特权

评论回复
| 2019-11-9 16:33 | 显示全部楼层
频率多少,降压,L2用15nH似乎偏小。EN接上。D7臨时改用电阻Vin÷Iin试验来找原因。可能假货。

使用特权

评论回复
| 2019-11-9 16:48 | 显示全部楼层
输入电压从低到高,看看到多少V烧掉,耐压达不到规格书要求的话,估计是买到假货了

使用特权

评论回复
| 2019-11-9 17:27 | 显示全部楼层
考虑考虑焊接问题!

使用特权

评论回复
 楼主 | 2019-11-9 17:56 | 显示全部楼层
储小勇_526 发表于 2019-11-9 16:32
看了数据手册以及官方推荐的电路,你这个Vsense电压设计的应该有问题,在1.221V左右才是对的。 ...

是吗?我看的是0.8V   

760015dc68b9b110e6.png
642595dc68d2e8814d.png   应该不是这里的问题,因为我第一次焊板子可以输出12V


使用特权

评论回复
 楼主 | 2019-11-9 18:06 | 显示全部楼层
king5555 发表于 2019-11-9 16:33
频率多少,降压,L2用15nH似乎偏小。EN接上。D7臨时改用电阻Vin÷Iin试验来找原因。可能假货。 ...

频率是570kHz,默认的是。我用22uH也是,参考电路直接用TI 电源设计导出来的,感觉这三路有关联,现在三个TPS芯片全拆下来了,把关键的SS34拆了,把班长上的TPS5430S输入那一路24V接到外面的LM2596模块,学生电源来回开几次发现LM2596也坏....输出和GND短路,
787825dc68e8959213.png

使用特权

评论回复
 楼主 | 2019-11-9 18:07 | 显示全部楼层
lfc315 发表于 2019-11-9 16:48
输入电压从低到高,看看到多少V烧掉,耐压达不到规格书要求的话,估计是买到假货了 ...

行 我在试试

使用特权

评论回复
 楼主 | 2019-11-9 18:24 | 显示全部楼层
lfc315 发表于 2019-11-9 16:48
输入电压从低到高,看看到多少V烧掉,耐压达不到规格书要求的话,估计是买到假货了 ...

学生电源限流0.08A,电压从1.2V往上加,TPS5430全部断开 就TPS54331工作,电压升的过程中会看到当3.7V时,学生电源回短路开路来回跳,继续增加电压,发现没有短路现象,明显感觉到开关切换速度加快,现在就不烧了,我也没敢直接关电加电,难道是开关频率不对??

使用特权

评论回复
| 2019-11-9 18:24 | 显示全部楼层
liu4195381 发表于 2019-11-9 18:06
频率是570kHz,默认的是。我用22uH也是,参考电路直接用TI 电源设计导出来的,感觉这三路有关联,现在三 ...

这种情况,估计是你的“学生电源”上电时有过冲,瞬间输出电压太高;
可以把“学生电源”先打开,再手动把TPS54331的输入接过去,避开“学生电源”上电稳定这段时间。

使用特权

评论回复
| 2019-11-9 18:52 | 显示全部楼层
lfc315 发表于 2019-11-9 18:24
这种情况,估计是你的“学生电源”上电时有过冲,瞬间输出电压太高;
可以把“学生电源”先打开,再手动 ...

这样的浪涌也很大。。。

使用特权

评论回复
扫描二维码,随时随地手机跟帖
您需要登录后才可以回帖 登录 | 注册

本版积分规则

我要发帖 投诉建议 创建版块 申请版主

快速回复

您需要登录后才可以回帖
登录 | 注册
高级模式

论坛热帖

关闭

热门推荐上一条 /5 下一条

在线客服 快速回复 返回顶部 返回列表