查看: 165|回复: 13
收起左侧

[技术求助] 问下IAR7.0的支持cc2650的开发么

[复制链接]

77

主题

3430

帖子

1万

积分

资深工程师

 楼主| 发表于 2016-8-19 22:53 | 显示全部楼层 |返回版面||阅读模式
最近接触到cc2650的开发的,安装的开发集成环境是iar7.0的,最后发现一个问题的,选择芯片型号的时候,里面尽然没有该型号的。。。顿时石化了 。。

77

主题

3430

帖子

1万

积分

资深工程师

 楼主| 发表于 2016-8-19 22:54 | 显示全部楼层 |返回版面
但事后的发现前边人开发的时候就是用iar7.0的版本做的开发,有些不明白了
      

550

主题

2万

帖子

8万

积分

版主

发表于 2016-8-20 09:15 | 显示全部楼层 |返回版面
smilingangel 发表于 2016-8-19 22:54
但事后的发现前边人开发的时候就是用iar7.0的版本做的开发,有些不明白了 ...

你的iar是什么版本?
要iar for arm的才可以。
cc2650用的是ARM Cortex-M3内核
昵称:灰小子 业务QQ:1358611172
欢迎进入TI MCU论坛      21ic TI技术交流1群:61549143(已满),  21ic TI技术交流2群:311421422
提供免费的21ic下载频道资料下载服务
      

550

主题

2万

帖子

8万

积分

版主

发表于 2016-8-20 09:16 | 显示全部楼层 |返回版面
也可以用最新的ccs,官方推出的IDE兼容性比较好
昵称:灰小子 业务QQ:1358611172
欢迎进入TI MCU论坛      21ic TI技术交流1群:61549143(已满),  21ic TI技术交流2群:311421422
提供免费的21ic下载频道资料下载服务

78

主题

3410

帖子

1万

积分

资深工程师

发表于 2016-8-20 17:17 | 显示全部楼层 |返回版面
楼上的也说了,需要的是IAR for arm的版本的啦

78

主题

3410

帖子

1万

积分

资深工程师

发表于 2016-8-20 17:18 | 显示全部楼层 |返回版面
不过你这个7.0的版本貌似是针对arm的,至于没有型号可选的,那就再用高一点的版本的被

78

主题

3410

帖子

1万

积分

资深工程师

发表于 2016-8-20 17:19 | 显示全部楼层 |返回版面
还一个就是可以给该版本打补丁的试试,,不过不建议这样做的。。

12

主题

183

帖子

549

积分

高级技术员

发表于 2016-8-20 18:57 | 显示全部楼层 |返回版面
建议用CCS,例程和仿真支持的比较好。

99

主题

598

帖子

1794

积分

助理工程师

发表于 2016-8-20 21:54 | 显示全部楼层 |返回版面
iar7.0是哪个版本

120

主题

804

帖子

2418

积分

初级工程师

发表于 2016-8-20 22:18 | 显示全部楼层 |返回版面
IAR有for arm的,for 430的,for 51的

25

主题

1215

帖子

3649

积分

中级工程师

发表于 2016-8-20 23:43 | 显示全部楼层 |返回版面
这个是for arm的版本的,可以选择7.3的版本的

22

主题

1245

帖子

3735

积分

中级工程师

发表于 2016-8-21 17:26 | 显示全部楼层 |返回版面
7.0的版本本省是不支持该MCU的,除非打补丁包的。。

28

主题

1233

帖子

3709

积分

中级工程师

发表于 2016-8-21 19:15 | 显示全部楼层 |返回版面
楼上几位说的是,可以用高一点的版本的就可以解决问题的。

25

主题

850

帖子

2560

积分

初级工程师

发表于 2016-8-21 19:46 | 显示全部楼层 |返回版面
用CCS的比较好的
您需要登录后才可以回帖 登录 | 注册

本版积分规则

分享 快速回复 返回顶部 返回列表