[电路分析] 求教PMOS开关电路问题

[复制链接]
808|16
 楼主 | 2018-9-28 17:28 | 显示全部楼层 |阅读模式

如图所示,实际测试中发现,两管G极给低电平时,D极输出3.3V电压正常。两管G极给高电平时,Q1的D极会有1V的电压输出,而Q2的D极会有0.4V的输出。求各位大侠分析……



本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?注册

x
| 2018-9-28 21:45 | 显示全部楼层
GS极电压没放掉,应加上个电阻
 楼主 | 2018-9-29 16:11 | 显示全部楼层
ouyang2253 发表于 2018-9-28 21:45
GS极电压没放掉,应加上个电阻

是在GS之间加电阻吗?我在GS之间加了个10K电阻,问题没变!

评分

参与人数 1威望 +1 收起 理由
king5555 + 1 SG并电阻,输出对地也并电阻因电容10uF放不完电。
| 2018-10-6 15:12 | 显示全部楼层
问下MCU 控制信号电压多少呀?是5V还是3.3V?看MOS规格书,上面写着最小的VGS(th)为-0.5,是不是控制电压与源极电压压差有问题,造成微导通?你换下MCU控制电压试下。查下问题在哪里?
| 2018-10-12 10:25 | 显示全部楼层
可能是MOS管漏电流问题
| 2018-10-18 16:15 | 显示全部楼层
如果你mos管后端电路的功耗非常小,就算mos管关断也会有电压的,这是因为mos管漏电流的存在。所以很多低功耗设备开关不用mos管
| 2018-10-19 09:55 | 显示全部楼层
R17、R18为何用1K?
| 2018-10-19 10:08 | 显示全部楼层

不是一定要1K的,看你项目开关频率需求以及G极驱动电压定的,这个电阻主要是控制G极充放电时间的。
| 2018-10-19 10:14 | 显示全部楼层
这个问题你可以在G极加一个10K左右的接地电阻试试,因为不知道你前面的电路情况,有可能是G极控制端在关断的时候直接悬空而不是接地将电流卸掉。
 楼主 | 2018-10-22 11:38 | 显示全部楼层
comeon1 发表于 2018-10-6 15:12
问下MCU 控制信号电压多少呀?是5V还是3.3V?看MOS规格书,上面写着最小的VGS(th)为-0.5,是不是控制电压 ...

还没有解决,手上板子数量有限,有些实验不方便做,目前看来有可能是后边有其它芯片引脚上还有电压,相当于将它嵌位了。关断后有1V电压那一路上,发现后边有个IO脚有3.3V上拉,将这个上拉去掉后,关断后就变成0.4V了,关断后两路的这个0.4V现在还没解决。
| 2018-10-23 09:45 | 显示全部楼层
johnsy 发表于 2018-10-19 10:08
不是一定要1K的,看你项目开关频率需求以及G极驱动电压定的,这个电阻主要是控制G极充放电时间的。 ...

1K是不是太大了?mos管导通速度太慢,发热会比较严重。这个电阻一般都是100ohm以内。
| 2018-10-24 12:58 | 显示全部楼层
天行剑 发表于 2018-10-23 09:45
1K是不是太大了?mos管导通速度太慢,发热会比较严重。这个电阻一般都是100ohm以内。 ...

嗯,导通太慢可以把这个电阻换小一点,或者提高G端电压(在允许范围内)。发热跟G端电压没关系,跟你MOS管导通后电流以及体电阻有关系。
| 2018-10-24 19:26 | 显示全部楼层
这个可能是MOS管的问题,因为我也遇到过,换了个管子就没问题了
 楼主 | 2018-10-25 09:45 | 显示全部楼层
virtuousliu 发表于 2018-10-24 19:26
这个可能是MOS管的问题,因为我也遇到过,换了个管子就没问题了

你是说本身管子质量问题,还是选型有问题
| 2018-10-25 19:31 | 显示全部楼层
可能是管子有质量问题
| 2018-10-28 21:36 | 显示全部楼层
这样的开关管子很多,我以前用过连电阻都不用加。
| 2018-10-29 01:22 | 显示全部楼层
ERYYYY
扫描二维码,随时随地手机跟帖
您需要登录后才可以回帖 登录 | 注册

本版积分规则

快速回复

您需要登录后才可以回帖
登录 | 注册
高级模式
我要创建版块 申请成为版主

论坛热帖

关闭

热门推荐上一条 /8 下一条

快速回复 返回顶部 返回列表