求大神们看看这个电源波形是什么造成的

[复制链接]
877|16
 楼主 | 2019-8-28 14:37 | 显示全部楼层 |阅读模式
本帖最后由 ysmmm 于 2019-8-28 14:38 编辑

这个是一个可调节LDO输出的电压 现在波形是这样的 请问这个波动是什么造成的呢  是按照官方的手册接的
539197ff911e887ae8eec33d93962a2.jpg

使用特权

评论回复
| 2019-8-28 15:19 | 显示全部楼层
负载波动。几个纳秒的波动,速度很高。
回路阻抗导致的,电源到负载的线路太细/太长、过孔偏多、寄生电感较大、滤波电容偏小/偏少之类。 0.1V压降,的确不算小。  另外,这种高频波动,绝大多数 LDO 来不及处理。

使用特权

评论回复
 楼主 | 2019-8-28 15:53 | 显示全部楼层
wh6ic 发表于 2019-8-28 15:19
负载波动。几个纳秒的波动,速度很高。
回路阻抗导致的,电源到负载的线路太细/太长、过孔偏多、寄生电感较 ...

大神我现在还有个ldo 有一个周期为1ms左右的也是0.1v的波动 请问是什么造成的 也是因为pcb电容的问题吗
造成这些波动的原因是因为电路的寄生的电容电感和元器件产生了自激振荡吗

使用特权

评论回复
| 2019-8-28 16:10 | 显示全部楼层
ysmmm 发表于 2019-8-28 15:53
大神我现在还有个ldo 有一个周期为1ms左右的也是0.1v的波动 请问是什么造成的 也是因为pcb电容的问题吗
...

1mS宽度波动,LDO可以处理,定位为LDO输出到负载间线路,估计是直流电阻影响的成分多一些。
主要是负载电流变化,在回路阻抗/电阻上产生压降变化。 一楼的看着没有规律,应该不是自激。三楼描述的没有图,难以判断。

使用特权

评论回复
 楼主 | 2019-8-28 16:23 | 显示全部楼层
本帖最后由 ysmmm 于 2019-8-28 16:24 编辑
wh6ic 发表于 2019-8-28 16:10
1mS宽度波动,LDO可以处理,定位为LDO输出到负载间线路,估计是直流电阻影响的成分多一些。
主要是负载电 ...

大神这是波形图   还有个问题就是第一幅图那种波形可以用滤波电路消除吗
96380d127bc7d3b4b434bcc41d7558c.jpg

使用特权

评论回复
| 2019-8-28 17:02 | 显示全部楼层
负载是什么,嵌入式高频MCU?  LDO 输出电流量过没有?

  看5楼的图,不是自激振荡。是明显的开关类负载变化导致。 1楼的图是同一个板子? 如果是,并且对高频纹波敏感,需要重新 Layout PCB。   如果不敏感,可以找一条0.75方以上的绝缘皮电线,并联在 LDO 输出到负载之间,负载电源脚附近加焊去耦、滤波电容,估计可以暂时解决。

   如果能找到 毫欧表,可以 断电 量一下LDO到负载间 PCB 线路的电阻,10 x 10厘米的PCB,良好布线时,这个电源回路的线路电阻,通常低于10毫欧。
      需要注意的是过孔一般是沉铜制作,只有一盎司PCB厚度一半,一个 30mil 的中号过孔电阻就大约有2毫欧。而且过孔的寄生电容、寄生电感都不小。一般大电流线路,无法避免过孔时,可以多并联几个过孔,降低阻抗。

使用特权

评论回复
 楼主 | 2019-8-28 17:18 | 显示全部楼层
wh6ic 发表于 2019-8-28 17:02
负载是什么,嵌入式高频MCU?  LDO 输出电流量过没有?

  看5楼的图,不是自激振荡。是明显的开关类负载变 ...

好的 多谢大神 我去试试

使用特权

评论回复
 楼主 | 2019-8-28 17:20 | 显示全部楼层
ysmmm 发表于 2019-8-28 17:18
好的 多谢大神 我去试试

大神我还有个问题就是这种波动可以用滤波电路滤除吗 刚刚学电路不太懂

使用特权

评论回复
 楼主 | 2019-8-28 17:21 | 显示全部楼层
wh6ic 发表于 2019-8-28 17:02
负载是什么,嵌入式高频MCU?  LDO 输出电流量过没有?

  看5楼的图,不是自激振荡。是明显的开关类负载变 ...

大神我还有个问题就是这种波动可以用滤波电路滤除吗 刚刚学电路不太懂

使用特权

评论回复

评论

ysmmm 2019-8-28 17:29 回复TA
@wh6ic :好的 十分感谢 
wh6ic 2019-8-28 17:25 回复TA
较难滤除 
| 2019-8-28 18:56 | 显示全部楼层
是不是用的高倍率探头,示波器已经到灵敏度极限了?。。

使用特权

评论回复
 楼主 | 2019-8-29 09:45 | 显示全部楼层
戈卫东 发表于 2019-8-28 18:56
是不是用的高倍率探头,示波器已经到灵敏度极限了?。。

我也不知道是不是高倍率的 就是买来示波器送的那种普通的     不过我调到200mv一格就看不到波形 最小500mv一格才能看到波形

使用特权

评论回复
| 2019-8-29 10:12 | 显示全部楼层
你的示波器是假的吧。。。???

使用特权

评论回复
| 2019-8-29 23:40 | 显示全部楼层
换个示波器还有探头,也可能是测试方法的问题

使用特权

评论回复
| 2019-8-30 09:42 | 显示全部楼层
他用的DC耦合,比较高的电压,Y轴很大的偏移,示波器的ADC浪费了很多BIT在空白上。
波形显示的地方只能100mV一跳了。

这种时候应该用AC耦合,波形就正常了。

使用特权

评论回复
| 2019-8-31 00:26 | 显示全部楼层
基本上都是layout上的问题。

使用特权

评论回复
扫描二维码,随时随地手机跟帖
*滑动验证:
您需要登录后才可以回帖 登录 | 注册

本版积分规则

我要发帖 投诉建议 创建版块 申请版主

快速回复

您需要登录后才可以回帖
登录 | 注册
高级模式

论坛热帖

关闭

热门推荐上一条 /3 下一条

在线客服 快速回复 返回顶部 返回列表