[技术问答] KEIL编译报L6002U错误。

[复制链接]
152|4
 楼主 | 2019-11-25 10:47 | 显示全部楼层 |阅读模式
大家好,我从官网下载的例程编译的时候报一下错误,请指教!不胜感激!
  1. Build started: Project: demo
  2. *** Using Compiler 'V5.06 update 6 (build 750)', folder: 'C:\Keil\ARM\ARMCC\Bin'
  3. Build target 'Demo'
  4. compiling ac78xx_ckgen.c...
  5. compiling ac78xx_debugout.c...
  6. compiling ac78xx_spm.c...
  7. compiling system_ac78xx.c...
  8. compiling ac78xx_dma.c...
  9. compiling ac78xx_eflash.c...
  10. compiling ac78xx_gpio.c...
  11. compiling ac78xx_uart.c...
  12. compiling ac78xx_timer.c...
  13. compiling ac78xx_wdg.c...
  14. compiling ac78xx_spi.c...
  15. compiling ac78xx_i2c.c...
  16. compiling main.c...
  17. linking...
  18. .\Objects\demo.axf: error: L6002U: Could not open file .\objects\ac78xx_ckgen.o: No such file or directory
  19. Finished: 0 information, 0 warning, 0 error and 1 fatal error messages.
  20. ".\Objects\demo.axf" - 1 Error(s), 0 Warning(s).
  21. Target not created.
  22. Build Time Elapsed:  00:00:01
复制代码

使用特权

评论回复
| 2019-11-25 13:26 | 显示全部楼层
看 log是.\objects\ac78xx_ckgen.o这个文件找不到,但前面看对应的c文件又编译了,建议把工程里面生成的RTE,Listings,Objects三个文件夹删除再重新编译试下。

使用特权

评论回复
 楼主 | 2019-11-25 18:17 | 显示全部楼层
JasonLee27 发表于 2019-11-25 13:26
看 log是.\objects\ac78xx_ckgen.o这个文件找不到,但前面看对应的c文件又编译了,建议把工程里面生成的RTE ...

把前面说的三个文件夹删除了后编译,问题依然存在。

使用特权

评论回复
| 2019-11-26 09:16 | 显示全部楼层
Rhizobium 发表于 2019-11-25 18:17
把前面说的三个文件夹删除了后编译,问题依然存在。

能否把有问题的工程发出来,这个问题在我的电脑上没有遇到,我没法确定是什么原因。

使用特权

评论回复
| 2019-12-4 15:40 | 显示全部楼层
感谢分享

使用特权

评论回复
扫描二维码,随时随地手机跟帖
*滑动验证:
您需要登录后才可以回帖 登录 | 注册

本版积分规则

我要发帖 投诉建议 创建版块 申请版主

快速回复

您需要登录后才可以回帖
登录 | 注册
高级模式

论坛热帖

在线客服 快速回复 返回顶部 返回列表